EX4100 Volumes degraded, now what?

Long story short my son apparently played around with my Ex4100 and open one of the lots while unit was powerd on.
When realising this i put the drive back in, don’t remember if i powered the unit of first.

Anyway. Logged in to the dashboard and i got a warning that disk one could not be read and the warning after that it was degraded and i think at the same time second disc got degraded. The Ex told me to run a disk test and i did and there where no problems.

The status now i that i got to 6tb disks in raid1 that are degraded and the Ex powers up the two red lights are flashing and the status display says “raid roaming enabled”. Also tried to go in to the raid settings and rebuild the disks but no such option is visible.

So before i do anything i thought id ask you guys what to do next?
Am i suppose to buy another hd and put it in slot 3? Ive googled and haven’t found any answers so any help would be much appreciated.



I had a similar situation with my EX4100 (although I can’t blame it on my son!). At the time, I had 2 4TB drives, in bays 1 and 2 respectively, and I was adding in 2 new ones in bays 3 and 4. Volume 1 was a RAID 1 structure using disk1 and disk2. The disks in bays 3 and 4 were unused.

After I received the ‘degraded’ message on the RAID 1 structure, I was concerned, as you are. I ensured that the shares and files were still intact.

WARNING: I am not suggesting that you do this, only letting you know my experience, ok?

I powered down the unit, and then removed the disks in bays 1 and 2. I restarted the unit, and I formatted the 2 new disks (this may not apply to you). After they were formatted, I again powered down the unit and put the disks that had been in bays 1 and 2 back into their bays. After restarting, I was given the message that the unit was now in RAID roaming mode - apparently thinking that the RAID array was from another WD EX4100. The rebuild command was an option, which I tentatively accepted. 10 hours later, all good.

Again - I am NOT saying that you should do this, just giving my experience. The documentation is poor when it comes to what to expect (or not to expect). I think that the rebuild is what I needed all along, but I’m not sure.

Happy to give additional details if you wish.

Good luck - back up your degraded volume if you can before trying anything.

Hey thanks for the advice!
I bought two new hard drives and followed your steps to see if i at leas would get the rebuild option available, but no luck. I sent a message to support but no answer and thats soon a month ago.

So conclusion when everything works it works great and when things go wrong there isnt much help or documentation about it. If i known this i would probably gone for another Nas. But then again when it works it worked great.

Not sure what to do next but i think ill have to fina stationary pc and tty to retrieve the files in that way.
Or anybody got any other idea what to do?


Hey Mark,

I ended up using a SATA dock to examine the drive(s) on a Ubuntu Linux machine I have (it’s an old Macbook Pro that boots up into Ubuntu). I also used R-Studio’s excellent file recovery product. All data were moved to a temporary external drive (40 hours of transfer time).

After a full system reset, and reconfiguration of the RAID array, I was able to move the items from the external drive back to the WD. It was a PITA for sure, but it’s done. I have additional drives in the WD4100EX unit as JBOD to act as internal (incremental) backups as a belt and suspenders, if you know what I mean.

Hope this helps in some small way.