EX4100 becomes unresponsive, loses network

Got to 33 days and looks like it crashed and auto rebooted last night…

Changing IP packet to Jumbo Frame at 9000 in place of 1500 by default, help a bit it will lock up in 4 days in stead of 1 day as usual.

I had a stretch of about 3 months where this happened weekly, no reason, just dead had to pull the plug to get it running again.

I took down any 3rd party software and only reinstalled what i actually use, and as far as that issue i havent seen it much as of late, but im sure its just waiting for the right time when i really need it working to hang.

its a chronic issue though and needs to be addressed

Here is a list of the reboots of my NAS for the last few months since I put in palce the cron job every 5 mins.

root@WDMyCloudEX4100 Public # grep "up 1[12345] min, " five_min_cron.out.old
2017/07/11 07:55:03 07:55:03 up 13 min, load average: 0.64, 0.90, 0.71 0
2017/07/11 18:20:03 18:20:03 up 13 min, load average: 0.29, 0.59, 0.51 0
2017/07/11 21:35:03 21:35:03 up 11 min, load average: 1.21, 1.21, 0.72 0
2017/07/15 13:55:03 13:55:03 up 13 min, load average: 0.18, 0.59, 0.55 0
2017/07/16 11:40:03 11:40:03 up 11 min, load average: 0.26, 0.36, 0.30 0
2017/08/18 21:55:03 21:55:03 up 13 min, load average: 1.01, 1.70, 1.15 0
2017/08/29 15:50:03 15:50:03 up 12 min, load average: 1.15, 1.52, 1.03 0
2017/09/04 16:05:13 16:05:13 up 14 min, load average: 0.30, 0.38, 0.33 1
2017/09/04 18:35:13 18:35:13 up 11 min, load average: 0.21, 0.40, 0.35 1
2017/09/10 11:40:03 11:40:03 up 11 min, load average: 0.71, 1.79, 1.12 0
2017/09/18 04:50:03 04:50:03 up 14 min, load average: 1.53, 1.98, 1.47 0
2017/09/30 14:40:03 14:40:03 up 12 min, load average: 1.14, 2.39, 1.49 0
2017/10/07 10:50:03 10:50:03 up 13 min, load average: 0.44, 1.35, 1.01 0
2017/10/13 17:05:04 17:05:04 up 15 min, load average: 0.70, 1.42, 1.21 0
2017/10/14 16:15:30 16:15:30 up 11 min, load average: 1.24, 2.02, 1.19 0
2017/10/14 16:20:03 16:20:03 up 15 min, load average: 0.61, 1.19, 1.05 0
2017/10/14 20:05:03 20:05:03 up 12 min, load average: 0.84, 2.31, 1.47 0
2017/10/17 12:10:03 12:10:03 up 15 min, load average: 1.14, 1.79, 1.41 0
2017/10/17 14:20:03 14:20:03 up 14 min, load average: 0.44, 1.32, 1.07 0

There is a few days there where the NAS rebooted a few times (some of the “15 mins” are duplicates). There is no rhyme or reason behind the reboots / lockups. No different activity on the NAS and some are even when no one is home to cause any load on the NAS.

The sounds of crickets from WD on this is very disappointing!

I am having the same issues with ex4100 becoming unresponsive, and I would like to try your solution JediNite, By I am not an expert.

How can I create this script and add the cron job?
Do I create a text file in /etc/cron.d with your 3-line code to create the script?
Then how do I add the cron job after the RAID device is mounted?

Thank you in advance

@panandreas

There is a link in the forums at Aliquam erat volutpat which details how to make the changes.

I have a script on my system in a directory called “/mnt/HD/HD_a2/scripts”. I created this directory via an SSH session and not via the web GUI. In this folder I have a script called “five_min_cron.sh”. The script is as per attached.

five_min_cron.sh.txt (1.1 KB)

I am also running entware-ng on my NAS so this script also sets up that environment and starts up the applications I run within that environment.

The entry in my /usr/local/config/config.xml file is as follows:

.
.
           <crond>
                    <list>
                            <count>7</count>
                            <name id="1">stime</name>
                            <name id="2">wd_crontab</name>
                            <name id="3">app_get_info</name>
                            <name id="4">recycle_bin_clear</name>
                            <name id="5">chk_wfs_download</name>
                            <name id="6">ga_cron_q</name>
                            <name id="7">ga_cron_d</name>
                            <name id="8">five_min_cron</name>
                            <name id="9">random_check</name>
                            <name id="10">user_expire_chk</name>
                            <name id="11">fw_available</name>
                    </list>
.
.
                    <five_min_cron>
                            <count>1</count>
                            <item id="1">
                                    <method>3</method>
                                    <1>*/5</1>
                                    <2>*</2>
                                    <3>*</3>
                                    <4>*</4>
                                    <5>*</5>
                                    <run>/mnt/HD/HD_a2/scripts/five_min_cron.sh</run>
                            </item>
                    </five_min_cron>
.
.
           </crond>
.
.

Sorry about the formatting, but if you need a copy of the file I can try and upload it once the details on my own NAS configuration are removed.

Once all in place, reboot it and check.

Cheers,

JediNite

Thank you very much JediNite!!!

I have created your script (starting from the ping command and all the way down) and changed /usr/local/config/config.xml and after a reboot, I have seen the script output inside public folder.

Do I need entware-ng so this script is executed inside that environment, or does the “Reboot on Kernel Panic” commands work anyway???

@panandreas,

No need for the entware-ng stuff. I am running stuff like sickbeard which uses it, so is why I have it installed.

Cheers,

JediNite

Hi guys,
purchased MyCloud 4100 last week, and I have the same issue, and its happening EVERY DAY!
It’s so annoying and frustrating!!!
Is there some workable solution, or the only option is exchange (and pray that new one is ok)???

1 Like

I would like to know something.

after you pull the plug to get the system back up running. Wait an hour and then log into the web console. go to Settings, the Utilities, Then press View Logs.
are there any errors listed in the logs?

@Jeff_Davis

It comes up with “Power loss detected on port 1” type messages.

Cheers,

JediNite

Out of curiosity, do you have DLNA media server turned on?

@BMiller,

I have the Plex application installed on mine from the WD Apps page. I don’t use the Twonky DLNA that comes standard with the unit.

Cheers,

JediNite

Hi,
nothing there…
just logs of power loss, since I had to remove the power to reboot it…
This is sooo annoying!!! I am not confident in WD at all now!

2017 Nov 4 09:48:08
SYSTEM
System Has Rebooted From A Power Failure.

2017 Nov 3 18:01:49
SYSTEM
System Has Rebooted From A Power Failure.

2017 Nov 1 13:19:08
SYSTEM
System Has Rebooted From A Power Failure.

2017 Oct 28 13:40:08
SYSTEM
System Has Rebooted From A Power Failure.

2017 Nov 4 09:48:09
SYSTEM
Power loss detected on port 2.

2017 Nov 3 18:01:50
SYSTEM
Power loss detected on port 2.

2017 Nov 3 18:01:48
SYSTEM
The network link 2 is down or has become intermittent. Check your network

UPDATE:
After advice from WD support,
I did “40 seconds” reset procedure.
I kept the data, but reset the system…after that, I have set up all users again…
So far, it’s been 2 days, NAS is working without any issus so far…
let’s see

UPDATE:

Hang after 2 days…

:angry:

I tried a different tact on this issue. This may have been tried by others, however I just wanted to clarify this.

The suggestion has been to make the IP a static address. I have seen many statements that others have set the NAS IP as static, however it was said that they made the IP reserved. That made me think that DHCP and Reserved was being deployed. That is how I had mine set too and I had continuous issues with the “Lock-up”

I since have changed my Router DHCP range from x.x.x.2 - x.x.x.254 to x.x.x.2 - x.x.x.100. I then set my EX4100 to static and selected an IP above 100.

So far so good.

@RICHARD_BAUER,

I’ve always used a static IP Address on my EX4100 and it makes no difference. Yet another smokescreen from WD to try and cover up the real issues the unit has.

Cheers,

JediNite

OK guys, I’ve resolved my issue with the EX4100. You won’t like the solution but its probably the only one…

I opened a support ticket with WD, described the problem, told them I had been fighting with this since April and I would like to return the hardware for any other WD product of approximate value ( could be hard drives I don’t care ). Just don’t send me back an EX4100 because I’m convinced there is a hardware or firmware problem and its not environmental.

So I did some basic diagnostics and sent them my logs, and at the end of the day they approved an RMA. I returned the EX4100 housing and they replaced it with a PR4100. I reinserted my drives, configured it like before, and the thing has been running for 15 days without a glitch.

So there it is. If your device is under warranty, return it. That’s what they carry insurance for.

EDIT - If you go this route, I have read that you should replace your drives in the same slots you removed them from. *

@BMiller

Mine is out of warranty, plus live in Australia, so would be a pain to get back to WD. I have a work around but the EX4100 is a substandard product and would not recommend another WD NAS product to anyone!.

JediNite