EX2 Attached 4TB MyPassport USB-share mystery disconnecting and reconnecting under Windows

Warning-Detailed Post!
Have been using a USB 3.0 4TB MyPassport attached to one of the two USB ports on my older WDMyCloudEX2 (with the original 2 X 2TB Red’s installed).
Having previously been through and solved all the early Windows Networking issues, I am now experiencing a consistent dropping of the USB Share in Window file explorer both in Windows 10 and 7. I first experienced this when using VLC to watch a 55 min 1.8Gig recorded TV episode (MP4 file). Suddenly picture freezes. Exiting VLC and clicking on the USB share name in File Explorer gives a “Can’t connect to <\WDMyCloudEX2\sharename>, network name cannot be found” type windows error message; share is just plain not reachable. However if I wait a minute or two and try again the share restores itself the files and structure are intact but if I go back and continue the TV episode it will happen again and again. This is out the blue in the last week or so.
At first I suspected the host Windows 10 machine itself that I was using to network into the EX2, but after moving the EX2 to another house with a different LAN and using a Windows 7 laptop to network to the EX2 it happens here too. Nothing else has changed on the EX2 or its settings and safely disconnecting the 4TB MyPassport plugging it directly into the Windows 10 (or 7) laptop and checking it with WD diagnostics everyting reads healthy with no errors. The drive is about 80% full with 650Gigs to spare at this point could it be too full somehow for Windows and EX2 to maintain the share?
When the share disconnects from the EX2 I can log onto the EX2 webpae through Chrome and see the share properly listed under the top of screen dropdown menu. so the EX2 thinks it’s OK. Also tried deleting the little smbm.xml file which I do know has caused problems in the past for me when it got corrupted. Deleting it is safe to do because when you re plugin the drive to the EX2 the OS and Samba networking will recreate it. I did this and got a fresh smbm.xml file but share still is disconnecting.
The fact that in this behavior scenario that it restores itself after a minutes or so leads me to suspect some Windows (both 10 and 7?) networking config problem.
Odd that this is happening now after a couple of years using this drive without problems.
Any ideas, anyone?

My WD External Hard drive keeps connecting and disconnecting every I already went into power settings and disabled the USB selective Windows 8 Help Forums Its a My passport Ultra and I tried using a different cable and on all I discovered that the power supply board is not attached to the drive.