EX2 fails after attaching brand new mybook 4TB USB 3.0 drive (updated)

I just bought a WD MyBook 4TB with USB 3.0. Attached it to USB port 2 (I have a fully recognized and browseable older 1TB WD MyBook on port 1). The EX2 immediately becomes inaccessible. Win 7 says can’t find drive anymore. What’s wrong and how can I make this new external drive work with the EX2?

OK, here’s an update to my previous post which apparently no one in this community has also experienced (!) or knows how to remedy :wink:
After waiting a couple of hours with steady blue top light and continuously flashing middle and bottom lights (activity?) on the unit the new 4TB WD Mybook (with USB 3.0) connected to USB port 2 finally showed up and is browsable.
Great, but now I can’t get to the EX2 Dashboard. The device no longer shows up in the in the right hand pane of Windows Explorer (under the Attached Storage) when clicking on ‘Network’ in the left hand pane. I usually used that method click ‘properties’ of the EX2 to get its local address. If I expand ‘Network’ in my Win 7 Explorer, as I mentioned, the EX2 shares, including the new 4TB Mybook are visible and browsable. But the EX2 seems invisible to Win 7’s sense of my overall ‘Network’. Also I can’t see it if I use the 'Network and Sharing->see full map option.
I remembered my last local address for the unity and typing that directly into Chrome gives me ‘192.1681.65 refused the connection’. I’ve tried the Win 7 network wakeup method of turning off Network Discovery so that Win 7 will ‘find’ the device again but still no EX2 device shows up. I can ping that last address and receive replies with 1ms delays (good as it gets) but have no other way of reaching the EX2. All this started happening when I attached the new 4TB Mybook. Is there something about EX2 and USB 3.0, the size of the USB ‘share’ being 4TB or some other change in the way Win 7 ‘sees’ this device??? I believe I have the latest firmware last time I was able to get to the Dashboard.
Please anybody out there give me some help cause the device is out of warranty and WD is virtually useless otherwise.
Cheers, Mike

Just is case, you are missing a dot on the IP address.

Have you tried resetting the unit? Also, you can try to access the dashboard using the name of the drive.

Thanks for responding ERmorel.
Yes I did miss the dot in my typing.
I did get through to WD tech support (based on my free 30days support on the new 4TB drive).
Recommended to reset the unit with paperclip-in-hole for 40 sec while powering back up. It seemed to improve things…for a little while, i.e. the new 4TB drive appeared, the drive appeared as an attached storage device in Win 7 explorer and I could also access the dashboard. Alas then it when off the rails again and while this time, the drive didn’t disappear, the new 4TB share because totally unresponsive. WD tech support wants me to reformat the new 4TB Mybook. I suppose that’s a logical step since it seems that of the two WD Mybooks I have that the only one which gives the EX2 grief is the new one. WD Tech Support swears the USB 3.0 and the higher capacity doesn’t nominally change the EX2’s behavior.
I’m loath to reformat as the drive has many many folders and the whole copy process took me 3 days off and on as windows copy would report 7-15 hours to compete after selecting just a few folder to copy. My original 1TB Mybook has 911GB in multiple folders and with hundreds of thousands files and my SATA and USB speeds on an Intel i5 2500, 8 GB ram on ASUS MB and running Win 7 SP1 is not very efficient at file copy under those circumstances. I guess I should try disk mirroring instead…if I only had another large drive to spare.
I’ll report again on my progress.



  • Is the MyBook 4 TB still formatted as NTFS?
  • How much is many many many files and directories exactly?

Try this:

  • Safely remove the 4TB My Book

  • Turn off any and all 3rd party apps installed on the EX2

  • Turn off Twonky DLNA

  • Turn off iTunes

  • Turn off Cloud Service (aka the crawler)

  • Reboot the EX2

  • Enable SSH (do not be afraid)

  • Login via Putty and run this command top -d1

  • Attach the 4 TB My Book and watch the top output (more precisely, the Load Average)

          Load average: 0.22 0.33 0.36 
  • While watching top output and the load average, try to login to the dashboard

Report back the results:

  • Is the dashboard still inaccessible? (REST API)
  • What are the top processes consuming CPU and Memory?
  • What was the highest Load Average spike?


To the first two questions:

-Yes still formatted as NTFS

-342,867 files, 26,190 folders, 907 GB size on disk

Thanks for the list of steps to try.

I’ll go through them and report my results.




This gets more complicated in trying to diagnose the EX2’s behavior.

Having also spoken to tier 2 (I believe) tech support at the WD. I was advised to try a factory reset.

  1.  I removed to 4TB and powered off, poked the magic hole above the USB sockets and held it down for 40 sec while powering up.
  2.  Got into dashboard successfully when all lights settled down.
  3.  Deleted the default .twonkymedia share, turned off iTunes, Cloud Service and DLNA completely and re-enabled SSH.  Is there a specific twonky service under DLNA->Media Servers?
  4.  There are 4 factory installed apps by default: HTTP Downloads, FTP Downloads, P2P Downloads and Web File Viewer.  I’ve never used any of these and when I click and highlight them they minus sign icon is ghosted so can’t be uninstalled, right?
  5.  I reattached the 4TB. Lots of middle and bottom blue light activity for about 20 minutes during which Win 7 File Explorer couldn’t recognize the EX2.
  6.  Finally the bottom 2 blue lights went steady, the 4TB share showed up and all shares are fully browsable.
  7.  The EX2 was issued a new IP from my Netgear router on my LAN so I tried to browse the EX2 Dashboard.
  8.  Totally unsuccessful getting to Dashboard (Chrome says refused to connect) and SSH through WinSCP’s and Putty also reports ‘connection refused’.

All the while the shares visible in Win 7 file explorer are still browsable.

This is madness especially since I can’t connect with SSH or PUTTY to run the top –d1 command again.




Further Update: I rebooted my win 7 box and let the EX2 unit idle overnight just to see if there might be any change.
-All front panel lights remain blue and steady, indicating no activity?
-I still have good visibility of Shares on Win 7 Explorer and reading and writing to them shows no problems.
-My Netgear N300 router show it as an attached device at the new IP assigned to it after factory reset.
-I can Ping the IP address with 1ms returns and no errors.
-Chrome (or any web browser) still says refused connection at IP.
-WinSCP or PuTTY still says refused connection although before I lost network visibility SSH was turned on under the Dashboard.
-Tried a run of WD EX2 Setup (mcp2_windows_setup.exe) -it cannot detect the EX2 on my LAN.
-WD Discovery also cannot detect the EX2 on my LAN.
-WD Access menu (in my taskbar) has item ‘Wake up EX2’ after clicking that the item changes to read ‘WDMYCLOUDEX2’ which is ghosted.
-Idle CPU load unknown, as I can’t check without access to Dashboard(?);
-Anyone know another method to query status of an EX2?

Can anyone advise what my best next step is?