Error msg private share: can't save files

I have a My Book Live installed on a machine running Windows XP. I used the MyBookLive dashboard to create a new share, a private directory called “private” with access for me only.  It does not automatically show in Windows Explorer unless I sign in to WD2go.com and use the “Open in Explorer” function.

When ever I try to copy a file over to the private director using Windows Explorer I get the error message: “make sure the disk is not full or write-protected and that the file is not currently in use”. I can create folders but I cannot copy files.

By looking at the directory (or share named “private”) via right click/properties I can see it is formatted as FAT. Everything else I use (except for a small partition on my hard drive is) is NTSF. There are no other menu options like “Tools”, “Hardware”, “Sharing” or "Quota available to me when I’m viewing the properties dialogue box on this drive. I cannot reformat the drive because it does not appear under Computer Management/Storage/Disk Management.

Does anyone know how I can copy files to this share? Does anyone know if it has anything to do with the formatting and if I can change it? Thanks.

Ok, this is becoming a mysterious issue.

The fact that the properties say “FAT” makes it sound like your PC mounted the MBL via “WEBDAV” instead of CIFS.

Verify by opening a CMD prompt and type the command

net use

If your mapped drive lists as “Web Client Network,” then it is verified.

You will need to UNMAP the drive, then try rebooting your PC, and map it again.

And no, you can never format a NAS drive via the client computer, only through the NAS’s configuration page.

Hi Tony,

Thanks for your response. Here is what I got when I ran net use at the CMD prompt:

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:>net use
New connections will not be remembered.

Status       Local     Remote                    Network


OK           X:        \WDTVLiveHub\WDTVLiveHub Microsoft Windows Network
OK           Y:        \192.168.0.147\WDTVLiveHub Microsoft Windows Network
OK           Z:        \MyBookLive\Public       Microsoft Windows Network

The command completed successfully.

The private drive is not listed because I did not use  My Book Live - System Administrator (via WD2go.com) to open it. So I did,  re-ran the net use CMD and I got this response:

C:>net use
System error 1734 has occurred.

The array bounds are invalid.

To be sure this was related to opening of the private share I closed it and re-ran the net use CMD. Sure enough I got the information in the first screen dump I provided above - a list of the X, Y and Z drives.

Even when I ran it the first time there is no reference to whether it is a “Web Client Network” as you have written or not. I don’t know if this is essentially the same as what I appeared under Network as “Microsoft Windows Network”.

Also it is not clear to me based on what you’ve written which condition requires that I UNMAP the dirve. Do you mean if it is verified or not verified?

You will note that I’m running a WD TV LiveHub, not that I think that has any impact.

Thanks.