Enter owner password but can't access into dashboard

Hi everyone, 

As mentioned in the subject title, I had enter the password but can’t access into the dashboard. It keep go back to the UI page after key in the password. (not due to invalid password key in).

Anyone can help me~~


After I reset the MBL, the UI page show a blank page now. What should I do?

Anyone can help Thank you  

What web browser are you using? Do you still have access to the Public folder?

I´m having the same error, the password is ok but the login page reloads and keeps asking for the passwod, if wrong password is entered an alarm message is displayed.

so the password i´m using is correct but i´m stuck and can not go into the dashboard

Has anyone has an idea?

any help would be highly appreciated!


I’m experiencing this also. And after resetting (3 times!) and setting a new password, the same thing happens again.

Windows 7, Chrome 17, Firefox 10.

Edit: I still have access to the “Public” folder. I am just cut off from the admin area.


i have the same problem as above… and after reseting MBL i receive blank page… but still have access to the public folder

windows 7, chrome 17, firefox 10.

I now also only get a blank page, not even the login page mentioned earlier. I am effectively cut off from administrating the device. Luckily, my data is still available, but I must admit this is quite annoying.

either of you try Internet Explorer?

Same problem. 

Tried using Chrome and internet explorer

internet explorer, firefox and chrome… nothing happen…

http:///UI/learn_center/learn_main/en_US works, but that’s not really useful.

Have any of you upgraded the firmware lately, as it bricks the UI

I got the device a week ago or so, and I then updated to the lastest firmware. That didn’t break the UI, though. It wasn’t until trying to set a password that everything went bad.

I have the same problem and have updated the firmware to the latest version. Is anyone from WD monitoring this post or know how to fix this?

Just purchase my My Book Live today. Worked fine until I updated the firmware. I can no longer get into the setup. Reset button does NOT reset password. It does reset network settings. So the IP address changed. Leaving the admin password blank results in “invalid password”. Typing the password I set does not show an invalid password but redirects to a blank page. Originally, before resetting, typing the password I set resulted in a repeated “enter owner password” prompt. It did not tell me that the password was invalid. If I typed the password incorrectly, I would get “invalid password”. If I typed it correctly, I would simply get a repeated enter owner password prompt. How frustrating. Had the thing hooked up for an hour and now it appears ruined.

Update to my previous post.  The original password still works to view shares.  But it DOES NOT work to access the drive setup.  Looks like I’m completely stuck.  Awful.  Switched to WD from Seagate GoFlex because I thought I’d avoid issues like this.

The recent firmware does brick the UI.

No access to dashbord - similar case as above

No answer on forum so far

Could anyone find the solution? - pls help

There is no solution to this problem. WD must be aware of the problem but continue to ignore the community as there is no easy fix. The stupid thing is they leave the firmware up and allow people to continue to download it. You can’t update the corrupt firmware unless you can access the UI. Unfortunately as the UI is now bricked the only option is to remove the HDD from within the MyBook live case (warranty gone), connect the drive directly to a PC running Linux and then format the drive. I bricked my MyBook Live the day I bought it. I took it back to the retailer, told them it was DOA and got a new one on the spot. Knowing what I know now I haven’t downloaded the firmware again and the product now works. Having said that, it runs like a dog… So Slow!!! I would recommend anyone thinking of buying this product - don’t.

I’ve submitted a support ticket and will call them tomorrow also. Has anyone else done this…any luck?