DX4000 stuck at startup

Hello,

In order to install other software than Windows storage server I soldered the necessary wires to J23, connected USB to serial adapter and got access to BIOS. Did some changes - SATA to AHCI instead of RAID mode, BIOS size to 1280x1024 (it was too small and difficult to read), saved and now my DX4000 stuck at STARTUP INITIALIZING… Serial connection still works and I can see that boot process hangs with status A2.

Tried to reset BIOS settings as described here and it didn’t work. Removed all power and CMOS battery for long time, did reset again and still unable reset BIOS settings to default.

So, my NAS is unusable, but happily I don’t need to recover any data from it. Does anybody fell in this situation was able to recover? And how? Any help is greatly appreciated!

Another question - maybe J9 is not the CMOS reset jumper? On the PCB I see also

  • J3 - (12 pin)
  • J8 - (2 pin)
  • J10 - (2 pin)
  • J11 - (7 pin)
  • J15 - (10 pin)
  • J19 - (3 pin)
    Does anybody know what are these for?

J3 is connector for VGA monitor.
J8 one pin is gnd and the other is -SYS_RST connected to the 82801 PCH
J10 one pin is gnd and the other is the LPT_EN pin going to the SuperIO chip
J11 is an additional SATA connector
J15 is a dual USB2 header
J19 is for debug. middle pin is connected to +3.3V through 1K ohm resistor. Pin 1 is connected to PCH GPIO0 pin. Pin 3 is connected to GPIO56 on PCH.

The procedure described at the end of the linked thread is the correct CMOS reset, but since no one has ever done it, it is not known whether this is sufficient to bring a misconfigured system back from the dead.

Thank you for this info. If you have the pinout descriptions for VGA, SATA and dual USB please share. Especially VGA pinout… There is my hope to bring my NAS back to life :slight_smile:

About the CMOS reset - I tried it multiple times with no success. The only effect was that at startup an error message appears and quickly vanishes, before I was able to copy it. And then boot again stucks with status code A2. So, to everybody planning to play with DX4000 BIOS - do not change BIOS resoluton!!

J3 pinout is as follows:

J3-1 VGA Red => VGA pin 1
J3-2 VGA Red_gnd => VGA pin 6
J3-3 VGA Green => VGA pin 2
J3-4 VGA Green_gnd => VGA pin 7
J3-5 VGA Blue => VGA pin 3
J3-6 VGA Blue_gnd => VGA pin 8
J3-7 VGA HSync => VGA pin 13
J3-8 VGA HSync_gnd => VGA pin 5
J3-9 VGA VSync => VGA pin 14
J3-10 VGA VSync_gnd => VGA pin 10
J3-11 VGA SDA => VGA pin 12
J3-12 VGA SCL => VGA pin 15

The picture is blurry at 1024 x 768 resolution, but it is usable.

J11 SATA connector pinout is as follows:

J11-1 gnd
J11-2 TX+
J11-3 TX-
J11-4 gnd
J11-5 RX+
J11-6 RX-
J11-7 gnd

A standard SATA connector can be soldered to the board and works. I use this for SSD boot drive.

USB2 header is same as PC motherboard I think.

J15-1 +5V (need to install F1 1.3A fuse also)
J15-3 -USBP2
J15-5 +USBP2
J15-7 gnd
J15-2 +5V (need to install F3 1.3A fuse also)
J15-4 -USBP3
J15-6 +USBP3
J15-8 gnd
J15-9 No connect
J15-10 No connect

+5V supply on the DX4000 PCBA doesn’t have a lot of current. So it may get overloaded if you have two USB3 connections and two USB2 connections at the same time. Mouse or keyboard or memory stick should be no problem.

Great! I will put these ports in use… if I revive my NAS:-)

Soldered VGA port and it worked. Now I see American Megatrends logo, but startup process still stuck at A2 status code. But I was able to confirm that picture resolution is 1280x1024, exactly as I set it.

So, I’m where I started. Next thing I think to try is to de-solder BIOS flash chip and reprogram it. I think that there BIOS settings should be kept. Does anybody can dump a working BIOS chip? My current BIOS is version 2.13.1216, BIOS date: 10/18/2011 10:30:10 ver: 0ABYK015. If yours not exactly the same I will try it anyway… it may work. I have not much options :slight_smile:

The problem you’re seeing (postcode A2) is documented by AMI as “IDE Detect”. See: https://ami.com/ami_downloads/Aptio_V_Status_Codes.pdf

I’m not really sure what would cause that. Although you did change the SATA mode from RAID mode to AHCI mode, I haven’t seen that cause a boot hang before on the DX4000. Maybe remove any drives if there are any present or insert one or two, if there aren’t any present.

The fact that the screen resolution is still at 1280 x 1024, tells us that either the CMOS reset didn’t take, or the screen resolution parameter is not stored in CMOS. It’s certainly possible that setup saves that parameter in the bios flash image itself.

Check your personal messages about getting an image of the 0ABYK015 bios flash.

You are right, It doesn’t seem logical about this post code. I tried to boot with and without drives of any kind (HDD, USB HDD, Flash) without success. Booting in RAID or non-RAID mode should happen without any problems on a normal BIOS. Maybe there is a bug, or WD intentionally does not allow booting in any other way as a measure against using this NAS in other ways.

About the BIOS - thank you for your effort. I got an idea - if this resolution setting is stored in BIOS chip I will try to find it and change to something else, doesn’t matter what. I expect this to invalidate the BIOS settings checksum (it should be any) and will force BIOS to load it’s default settings. If it doesn’t work I will flash your BIOS as a last option.