Dropbox - it's app working?


I am trying to setup existing dropbox app on WD EX2 device (bought few weeks ago).

After enabling dropbox app, and going to configure then sign in button, Dropbox autorize request, but nothing happend on WD dropbox app, like callback URL is not working. (it’s just sign in button always there)

Have anybod success with enabling Dropbox app?

Welcome to the Community.

I’d recommend a device restart and then trying again. If this does not work maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country


Tnx, but it’s not that, have tried multiple combinations
(removed app, restart WD, or without removing app before restart)

don’t now if is related from which URL i am on WD dashboard (also tried over IP, some hostnameas as http://wdmycloudex2/)  and nothing

Will contact also support. 


I have the same problem. This Dropbox app never did anything since it was released. I would be very happy if this would work.

I am also having issues with this App. It stops syncing. I tried reinstalling the app, restarting the app, even reseting the drive to default settings as indicated by WD Tech Support. The problem is with the Dropbox App, it is just not reliable, it does not work properly.

I buy a EX2 today and find that Dropbox is not working!

Has anyone found a solution to this yet?