My Cloud EX2 Ultra not consistently synchronizing with Dropbox

Seems like there’s a theme of Dropbox problems with My Cloud. I only purchased this device because of the Dropbox synchronization feature, but it’s never consistently worked. I have to turn the app on and off, I’ve tried disconnecting the app and reconnecting it, also checked that the admin account is “admin.” Nothing seems to make a difference. It only seems to synchronize inconsistently and only the top-level of my Dropbox folder. It doesn’t seem to touch anything within subfolders of Dropbox. I called Support, but L1 argued with me and said that WD wasn’t responsible for the app and told me to contact Dropbox. I should have bought a Synology.

Have you contacted support over this? They will collect this information and pass it along.

Yes, I created a support case. I even mentioned in my initial post that I did that. I had to argue with Support over who is supposed to support that integration. They even made me open a case with Dropbox. FINALLY, someone got back to me last night via email, but his writing is so poor, I can’t even make sense of what he wants.

The main reason I wanted to make sure that you did send this into support in email format is that consistent issues get passed along for review by product people.

First, the download feature for providing support with data doesn’t work with any of the three browsers I tried with my Mac, even after turning off the pop-up blocker. Then the support staff person they assigned to me is TERRIBLE. I ultimately figured out the root cause myself. I watched the sync process and noticed that it always stopped on certain files/directories. I removed and or unchecked them for sync in the configuration and now synchronization is continuing. I must say, as a person who works for a technology company, this is a pretty poor implementation. I even had SSH’d to the device and manually parsed the logs to find something that would provide a clue. Your app is a silent Dropbox killer and I recommend you have better error checking/reporting added to the app.

I will pass this along.

and BTW, your Support app doesn’t work or doesn’t work on the Mac platform. When I choose the “create and save” option under the Support app in any browser, it doesn’t actually download anything. I’ve even turned off my popup blocker. Ariel from Support keeps asking me to do this and I tell him it doesn’t work, but I can gather the files via SSH. But for some reason, he thinks that means I DON’T UNDERSTAND HOW TO DOWNLOAD FILES. I don’t understand how anyone actually gets any useful assistance with staff like this. I’ve been very specific in my communications.

I do apologize for the hassle. I did escalate it and it’s being looked into.

Hi,
I have the same problem, I have sent a support request but no replay for two days.
I would appreciate a tip on where to look for the log files and fining the directories that get the app stack.

Thanks

I get the impression that Western Digital doesn’t even care about their My Cloud devices. They want to sell hardware. I forwarded logs and no one has ever responded to this case with feedback. I escalated to a manager and no one ever contacted me. I will NOT be purchasing WD products in the future.

Thnks, how did you pull the WD logs?

Zeev

@MC_64

You were sent an email requesting a day and time for our agent to call you. Did you ever get the email? It was sent on 3/19. And the case still shows open. If you just respond to any of the emails that you’ve received with a day and time to contact you, I’m sure they will respond.