Drive won't work with AHCI mode but RAID is OK


I bought two lightly used WD VelociRaptor WD5000HHTZ drives from one seller on eBay and a new WD5000HHTZ from another seller. One of the used drives has an odd problem which I’ve seen before but I couldn’t find a solution. The drive seems to work ok if the SATA controller is in RAID mode but as soon as I set Windows to work with a change of modes, restart my computer, and switch the controller to AHCI mode in the BIOS / UEFI my operating system (Windows 7 Pro 64-bit) will bluescreen sooner or later during startup or shortly after startup and blame the iastor.sys driver. I have an ASUS P8Z68-V Pro motherboard and the VelociRaptor drive is connected to a SATA II port so I’m just using the Z68 chipset’s integrated hardware controller. Basically I just connected each drive that I bought from eBay one at a time to a SATA II port and ran the extended test in WD’s Data Lifeguard Diagnostic for Windows program on the drive. If the drive that has problems is connected I’ll see a bluescreen error before I can start running the extended test.

I tried contacting the seller about this but mysteriously [sarcasm?], even though I had quick responses within minutes to hours when I was asking him questions about his items that were for sale, now that I have the drives and he has the money I have not heard back from him for two days. Ok, maybe he partied during the weekend and now he’s back at work. I don’t know. I shouldn’t wait for help from him with solving this.

I read that he used the three drives for a data migration project for two weeks last summer. I’m wondering what that exactly means. Were his three drives used in some kind of RAID configuration and something important was changed on the first drive in the array? Is the phrase ‘data migration project’ a euphemism for taking parts from a drive to repair another and save the data? The new drive and the other used drive that I bought seem to have no problems with the Intel Z68 controller’s AHCI and RAID modes. The other drive that is used and doesn’t have a problem has the same manufacture date as the one that has a problem. The seller listed a SANS DIGITAL EliteRAID ER104CT on eBay but I can’t view its listing anymore so I don’t know when it was removed, or ended, and I don’t know if he used the EliteRAID with the problematic drive anyway. I have an old Albatron PX915P Pro motherboard with SATA ports (btw, the audio and ITE RAID were garbage and I mention that every chance I have since Albatron’s support wouldn’t replace the board) and I could try connecting the VelociRaptor drive to it to see what happens but I doubt there will be any difference.

I mentioned that I had this problem before with a different drive. A while ago I bought some used WD Black WD1002FAEX drives and one of the drives had this same problem. Now that I’m having this problem with the VelociRaptor drive it seems like I read a similar description of what the WD Black drive was used for in its eBay listing. The seller told me the WD Black drive was used in a RAID configuration, if I remember correctly. Or, maybe the seller who I was chatting with back then just told me some bs and hoped I would go away. Unfortunately I wasn’t able to find a solution for that drive and eventually returned it to the seller for a refund. I hate it when I remember something useful after I’ve encountered a problem which could have helped me avoid the problem completely to begin with. Maybe I can find some old emails that will refresh my memory of what happened back then.

If this drive was altered purposefully somehow then I expect WD wouldn’t cover that with their warranty. Can I reconfigure the drive so that it will work correctly with AHCI mode? Anybody know of a RAID configuration or controller that can cause a drive to become unable to work with AHCI mode if not reconfigured? Should I check if all of the chips are on the circuit board of the drive?

IDK if this goes for RAID and SATA too but here is what I have come across in the past with IDE and SATA in the BIOS:

If you change the settings from IDE to SATA in the BIOS after windows is installed, you cannot boot.

If you change the settings back from SATA to IDE in the BIOS, you can boot.

If you set it to SATA and install windows, you can boot.

Unfortunatly the best things to do here is to:

Write to zeros on both drives

Select which setting you want to use (AHCI or RAID)

Install windows


Select which setting you want to use (AHCI or RAID)

Install windows


Select the setting that work and live with it until you want to do a reinstall of windows.

Maybe someone else has another opinion.

Good luck and I hope this helped.

Hi mjennings,

Thank you for your reply. I think Microsoft’s Windows really isn’t the problem. I took care of Windows not being able to automatically cope with changes of the SATA port’s mode.

Microsoft’s Official Solution for Windows 7:

Error Message Occurs After you Change the SATA Mode of the Boot Drive

Windows Server 2008 R2:

How to Change SATA Hard Disk Mode from IDE to AHCI / RAID in BIOS after Installing Windows

So far I’ve had no problems with using those solutions. Basically they set Windows to recheck how the SATA ports are working during the next startup instead of just assuming that nothing is different. Gigabyte even provides their own little program that changes the registry settings and BIOS setting for you while Windows is running so that only a reboot is needed. Also, I mentioned that Wnidows boots ok for me and has no problems with the other two drives that I bought. Only this one drive causes bluescreen errors for some reason.

Hehe, I think one of the reasons I’m having problems with finding a solution for this on the Internet is that anytime I try using Google to find more info about this problem the search results are cluttered with people asking for help, and others who are offering advice, beacuse they changed the mode of their computer’s SATA ports and now Windows won’t boot at all anymore. I’m not having problems with that.

I think I fixed whatever was causes the bluescreen errors. I was skeptical it would work but I tried something. In my computer’s UEFI I set the SATA ports to AHCI mode, booted using a GParted Live (Debian) cd (didn’t think this step would work), initialized all 3 disks as GPT, and chose the NTFS filesystem for each. Rebooted to Windows and so far there haven’t been any bluescreens. I tried starting Windows with and without IRST installed and so far it’s OK.

Why didn’t I figure this out the last two times I had this problem with drives I ordered from eBay? I didn’t mention this in my earlier post but now I remember this is the third time I’ve had this problem with a used drive bluescreening Windows while only using AHCI mode. I’m sure I would have tried booting Linux on those two earlier occassions but I don’t remember if I specifically tried booting using a GParted Live cd. In the past a drive formatted for some other operating systems may not work correctly in a Windows computer even if the old partition was removed before putting it in the Windows computer. There could be some traces left behind from the old partition or file system that Windows couldn’t deal with back then I thought Microsoft had sorted out those issues but I guess there were some bits remaining on that one drive from something. I’m curious about what the seller did with these drives.