DL4100 Not Sending Any E-mail Alerts

Drive 4 of my 5 year old DL4100 NAS failed S.M.A.R.T. with a code 3. Not surprising (I was expecting a failure for some time due to the age/usage of the device), I even ordered a new PR4100 on Friday.

What was surprising is that I didn’t know about it because the NAS has quit sending notifications. I have it set to send “Critical and Warning” alerts; but did not receive a single e-mail regarding the drive status.

I have already replaced the drive and rebuilt the RAID array; but the e-mail problem described herein persists. There are no other errors on Scan Disk or Quick Test. Tried unsuccessfully to run a Full Test, but it stops at about 10% and hangs with no progress even after 2-3 hours.

Other than adding a share or user, here and there, and firmware updates, this NAS configuration hasn’t changed in five years.

I know this functionality has worked in the past, because I still have some of the old alerts filed away from a few years ago. So, I tried sending a test e-mail, to no avail. I searched this community/site and tried the scant few suggestions, also to no avail. I tried searching the net for possible causes, to no avail.

It gets more confusing because if/when I send/resend a user’s MyCloud notification, the e-mail is sent (and received). E.g., resending a My Cloud notification to a user with the same e-mail address as the alert notifications succeeds; but sending a test notifications e-mail to the same address does not. So I know the Yahoo! mail server is not rejecting the no reply e-mail. I also tried deleting the e-mail address and adding it back, to no avail. I also tried changing the user e-mail to a different account on the same mail server, to no avail. I also tried changing it to accounts on two other mail servers, which includes G-Mail, and it [seemingly] does not send alert notifications or test e-mails.

Until the new NAS arrives, and I back up the data from this server, I did not want to try anything radical like restoring to factory settings or anything like it. I am assuming that this is something simple on my side that I can change or a bug/misconfiguration on the WD side that I cannot [change].

Does anyone have any idea what might cause this? More importantly, does anyone have any idea how to fix it?

Thanks in advance for your response.

  • DL4100
  • 8TB RAID 10 (16GB total–4x4TB drives)
  • Current Firmware Version: 2.31.204
  • Connected to a managed 802.3ad LAG/LACP switch, which is connected to a router. I can reach the Internet from the box–see My Cloud e-mail test above. I can also reach the box from the Internet via files.mycloud.com. I.e., connectivity is not the issue.

***NOTE: Current capacity is > 95%, which is the reason I bought a new PR4100. I doubt this is related; but you never know.

***NOTE: I have not tried rolling back the firmware to an earlier “known working” version; but due to the lack of posts on this issue, I doubt a firmware bug is the cause.

Follow up…

After several restarts, and jiggering w/ the e-mail accounts, it seems that I can eventually receive the test e-mails; but Yahoo! is holding/delaying them from landing in my account for a few hours. The first batch I tried last night/this morning finally showed up in the spam folder after 5-6 hours. I have since marked them as “Not Spam” and am currently waiting to see when (and where) my new test e-mail shows up.

Regardless, I still am not receiving notification e-mails. I.e., I moved the notifications slider to “All” and still haven’t received any e-mails. I.e., restarting the NAS should have sent an e-mail. Also, I passed 95% capacity and that should have sent a notification e-mail. I can see both of those alerts under the bell icon in the dashboard; but I have yet to receive any e-mail for either.

Took >5 hours to receive the last test e-mail; but it at least it is still sending.

Can anyone tell me why notification e-mails are not sent? Besides a factory reset, what else can I try? I am out of ideas here and looking for help.

Perhaps my understanding is incorrect (the manual lacks detail/clarity); but, as I understand it, setting notification e-mail setting to All includes informational, warning, and critical alerts. Informational should include a NAS reboot. At least, it used to.

Thanks in advance for any response.