Dissapointed with latest firmware

Recently I updated my WDTV Live media player to the latest firmware update, ok it has all the bells and whistles etc but to say the least I am quite dissapointed with this firmware update.

They say when a company brings out a firmware update its sometimes for the better, well not in my case and what makes me more mad is  that WD has done nothing about this and this update has been out for well over a month now, infact much more.

Well the problem with the latest firmware update is that now when I want to search for something in YouTube lets say and use the WDTV remote app on my Android phone I cant anymore and say for eg if I type in a search word, eg lets say Porsche on my Samsung Galaxy Note II using the WDTV app it will not search at all and I have to do this manually, sorry WD but are we actually going backwards, because I thought technology moves forward well not in this case.

What make me more angry is that this issue has been going for way over a month now and WD has done nothing at all to rectify and fix it.

To say the least WD I am not happy at all.


Sorry to hear you are experiencing this kind of situation. Have you tried uninstalling and reinstalling the App?

Also disappointed. Never got that far before reverting back to old firmware (didn’t play all my mp4 files, very slow to update thumbnails). Funny you mentioned re-installing the app, what **bleep** that is! Tried it on an Samsung S3, S2 & LG Optimus something. Laggy and app crashes after a while, even causes phones to freeze up! Using keyboard is so frustrating that one even prefer the remote! Not impressed!