Disappointed with the unit: plays almost no mp4

Just bought and installed the unit; updated to latest firmware as suggested during start-up. The unit refuses to play almost any mp4 file I provided (just played 1 or 2 out of 10+). Files are provided by means of a USB stick: I see the files but when attempting to play them, the unit holds on for a while (in some cases, but not all, it recognizes video length) and then reverts back to the list.

Shows similar problem also playing some mkv file.

Honestly I have to say I am very disappointed: bought the product to get rid of problems I had using other means such as BR player and/or TV itself to play this kind of video files and, as such, it is proving totally useless.

It is a good practice to confirm if the encoding used to create the files is actually within the supported parameters of your media player as .MP4 and .MKV are just extension containers, and can have several different codec variations. This means that while in file name alone you may have two .MP4 files, internally they could be extremely different in behavior. For this purpose I would suggest verifying the Media Info of unplayable files to confirm if the files themselves need to be re-encoded to use supported parameters.

More information on Media Info is available in the following link:


The list of specific combinations of codecs and containers supported by your Media Player is available in the appendix section of the User’s Manual.


There’s a bug in the latest version of firmwares for both this unit and the SMP that affects MP4 playback.

1 Like


Marketing claims of this unit state mp4 support … to me, 10% (at best) of successes in attempts to play mp4 is not acceptable at all.

I paid 80+ € for this unit and they are 100% good.

Hope firmware upgrade will sort out the problems soon, so far I just can say I find the situation really annoying.

1 Like

Agree with Avalon.

I had the first generation WD TV HD was 2009 I bought the new WD TV miracast (WDBPUF0000NBK). I update the firmware and then discover that many of my mp4 files before now reproduced normally does not.

I can dont believe. The problem is I do not know if the previous firmware does.

Anyone know if the above did and if so, what is its number firmware’

trilogico wrote:

I can dont believe. The problem is I do not know if the previous firmware does.

Anyone know if the above did and if so, what is its number firmware’

Had the same problem with Firmware 1.00.42   (which is the previous firmware revision to 1.01.30)

but in my case, 90% of MP4’s play fine … 10% don’t play   (which was the case for both 1.00.42 & 1.01.30)

All MP4’s play fine on all my older WDTV’s  (Gen1,Gen2 Live & Live Hub)

The MP4 issue has been reported to support, so hopefully next firmware release will resolve the issue.

1 Like

It’s hard to believe that the latest firmware revision has made things worst … if that’s the case I wonder what the quality test means to WD … 

Thanks Joey

All MP4’s play fine on all my older WDTV too
In my case, 80% of MP4’s play fine and 10% don’t play

I have also seen that there is a version that removed after numbered 1.01.26 Have you tried if this version work well?

trilogico wrote:

I have also seen that there is a version that removed after numbered 1.01.26 Have you tried if this version work well?

Thanks, i wasn’t aware of that version … since there is no official download or anything it the history release notes …

found this post   http://community.wd.com/t5/WD-TV-Media-Player/Firmware-1-01-26-for-WD-TV-Gen-2-WDBPUF0000NBK-00/td-p/775365

might do some searching    found the link

1 Like

Joey, looking for previous firmwares to see if it worked I found that version 1.01.26 but do not know if it will read all mp4. I doubt it, if you say that in the first and did not do it today either

Confirmed. I have tried versions 1.00.42 and 1.01.26 and do not solve the problem of mp4. In short it is a big mistake WD hopefully resolved quickly because it starts to feel indignant. I update five years after buying a new wd tv and now it does the most important thing is to read files, something I did in my current files on a device 5 years ago

I also encourage all the people who is upset with this situation to open a support ticket.

I did and I have been contacted to provide samples of mp4 not processed (well for some it’s a bit cumbersome since they are large files therefore for the time being I provided then with links of where I downloaded them from; for others, including mkv - have problems also with these - I will send the actual files).

1 Like

What MKVs? Mine work just fine for me. Post the Mediainfo text output of the files that don’t.

You could use Joey’s rollback info to test your mp4s on 1.00.42.

Thanks avalon. I have also contacted support

Techflaws. In version 1.00.42 not working

Techflaws, just let me know how to do that and I will. These mkv have been given to me, do not know how they were produced … thanks.

As far as the uploading of the files goes … I tried to access the ftp site I was provided and … it doesn’t work.

I am astonished.

Let me spend a couple of words.

This is the first media player I have. So far I have lived with playing stuff thru USB ports on the TV and/or the BR player. I went for the media player because as time goes by I was finding more and more frequently the situation in which I couldn’t play what I needed … but honestly I cannot blame a TV/BR manufacturer if it doesn’t continuously provide fw upgrades to catch up with new codec etc. for devices which are _ 4-5 years old now _, expecially because, for those devices, the capability to play content off USB sticks is a side feature.

This is totally different for this WD TV, which is brand new and whose core business is playing content that way. This unit looked good for me since at a reasonable price it offered what I was looking for (my main needs are really basic, at least for now I am not interested in streaming video from yt or other providers). 

In this sense, actually it is proving to be totally useless to me.

Avalon. As I said in another post I have the wd tv 5 years ago and for me has been one of the best purchases I’ve ever made. Sometimes something worse or updated and improved but still the device operation. As for reading files with no problems, others saw friends with other devices from other brands with problems and I assumed mine always reproduced all. Only in recent times has appeared some TS or FLV file not reproduced well. Five years later decide to repurchase the wifi and miracast, because as I say, I was very happy with the reproduction and now I have this problem with MP4 playback. I assume and hope that gets fixed soon with an update.

You neednt do a downgrade (put an old firmware) Very easy to do but I have tried that does not help our problem with files mp4 I Hope than soon WD surprise us with an update WD

pd: sorry for my english

Hi Trilogico …

in fact I purchased this unit after having browsed the Internet and realized that people with WD TV Live (since it’s old there’s a lot of information) were quite happy with that, as you are … I assumed of course that the new one would have been even better.

I want to believe WD will fix the problem soon … I saw the advise to downgrade the fw but looks like it doesn’t sort out things.

PS no problem with your english and by the way I’m not american/english too


I own a WDTV LIVE and been using it for over a year — and i am very much satisfied with it. This is the reason i wanted to buy the same units for my mom and sister, sadly there wasnt any available according to our local wd store so i decided to purchase the WDTV player they offered me instead and assumed it was also a good purchase since its from WD… seems to have been a grave error on my part. Lol

Anyway, i restored my moms WDTV to its factory default settings but still she is getting problems with the unit. Like most of you guys, i hope WD release a fix for these things soon