MP4/AAC sync fix - is it reasonable to assume it's not going to ever happen?


#1

And so I was tricked by rave reviews on AVSforum.com and on Amazon to purchase this nifty little box.  Unfortunately, MP4 w/ AAC playback was broken since the 1.01.11 fw back from 11/16/2009.  I waited patiently for a very long time, reading people’s complaints on the boards and checking weekly in hopes of a fw that finally addresses it.

Well it’s been 4 months, and I decided to give the latest “prerelease” a try.  MP4 / AAC is still as fubar’ed as ever.  As luck would have it, I guess I’m one of the few minority that happens to have 80% of his video collection in MP4 / AAC format.  I’m guessing I gotta be in the .1% percentile of WDTV Live users who have MP4 / AAC as their primary video collection format or why else would this blatantly broken function have stayed broken for over 4 months?

I guess I’m stuck using FW version 1.0, yeah the one that constantly drops out my network share drives, and plays back HD content kind of choppy, like some ghettomix of 3:2 pulldown.  Whats truly mindboggling though is why MP4 audio was flawless in the original firmware, but somehow became broken now in firmware updates that are supposed to “fix” problems.

And yeah I actually registered just so I can whine about this…  Call me out on it if you like, but I’m one of those rare consumers that thinks a product should work as it is advertised to, and if it’s broken, then it should be fixed based upon a reasonable timetable.  So I’m basically writing to convey that…no, I don’t think 4 months and going is reasonable, at all.


#2

Or you can take the ten seconds or so it will take to convert your MP4 into an MKV container using mkvmerge (and on audio select the AAC is SBR box) and be done with it (yeah, I know, it’s more fun to complain, but on a whole I’d just prefer watching my stuff play properly).

(And, not that you want to hear this, but I’m pretty sure that NO ONE from WD actually visits these boards.  These are user community boards, like the Apple ones, and thus no official presense here.  So you’re basically just preaching to the choir, which isn’t to say that’s not worth doing, just don’t expect any value from doing it).


#3

I am in EXACTLY the same position as you. Been waiting for it to be fixed since November. When you have a lot of files, remuxing isn’t a productive option to make up for a faulty box. I’m sick of WD sitting on their butts and I’m heading back to the store this weekend to return my two boxes. I never thought their support would be so poor after the success of the fist box where this problem doesn’t exist!


#4

I’m in the same boat as you guys - an no, converting 500+ files is not a reasonable fix - and shouldn’t be considered as one.


#5

Lol @mkelley, sorry but if you’re assuming my video library consists of 1 mp4 file that I can fix in 10 seconds, then you assumed wrong.  You also assumed wrong that it’s more fun to complain, because it’s not, it’s actually very frustrating, and only something I’m resorting to after months of waiting.  My goal wasn’t really to get some official to read my post because, obviously, if they haven’t read this complaint  from others by now, or cared to address it, then why would they address mine?  But since you brought that up, isn’t Bill_S someone “official”?  Yeah, he’s the guy who posts firmware update notifications on this board.  Because last I checked, he actually responds to people’s posts.  And yes, my goal exactly was to preach to the choir and vent along with others who are on the same boat as me.  I guess I actually see enough value in doing this to register an account and make my first post!

I’m glad that these problems with the WD Live have absolutely no effect on you mkelley and that you practice your due dilligence in working around all of the WD Live’s faults.  You are an absolute role model consumer, in fact WD wouldn’t even need to release another update ever again if we can all strive to be a little like you.


#6

Now it’s YOU that’s making a mistake – I have more videos in my collection than you ever could (sorry, but I do it for a living and have literally 10’s of thousands of them).  You can indeed batch process all your stuff and even for a few thousand it won’t take more than a day – (and easily far less time than you’ve spent waiting for a fix).

Bill’s a mod but I don’t see him as technical in any sense and complaining to him doesn’t solve anything.  Have you actually READ any of the messages on this board?  If so, you’d see no official response from WD and no fixes as a result.  About the only thing that’s official on this board is a wish/bug list and you should indeed post there.  But posting here is only bellyaching and while I don’t begrudge that (it does have theraputic benefits, truly) and even do some of that myself I was actually suggesting something that might help.  If you aren’t interested in solving your problem then that’s fine.  But ignoring a solution just because it’s not the one you want is just plain stupid.


#7

Okay?  I must have missed something here, what did I make a mistake about?  I don’t even care to assume anything about you, but sure, that’s great that you make videos for a living and have thousands more than I ever could, but I’m not even sure why you’re bringing it up?  Lol, I didn’t ask for a comparison to see whose got a bigger library.

You are right about one thing though, batch remuxing.  I never thought of that.  All my videos, though, are already organized into individual folders with appropriate movie posters + corresponding subtitles files (yeah I’m intensely OCD about keeping my video library organized).  How easy or hard is it to batch a group of mp4’s already organized into individual subfolders - I don’t really know?  But none of that matters, because the last time I checked, my xbox 360 in another room doesn’t support MKV.  Neither does my brother’s in his room.  By the way, this is all way more information than I should even need to inform you of.

You also need clarification, what you’re proposing as a “solution” is simply a workaround.  A solution would be to figure out a way to make mp4’s play appropriately on this little WD box.  But for the sake of humoring you, ok sure, am I stupid for not accepting your “solution”?  I guess everyone’s entitled to their opinion.  But since when did I say I’m not interested in “solving” my problem?  Apparently, my simpleton brain tells me that it’s much easier and more worthwhile of my time to just downgrade the firmware back to 1.0 in order to “solve” this problem.

You also seem fixated on the idea that my goal is to get some official WD employee to read my post and come to my rescue.  I already explained to you that I’m simply venting.  I have been an owner of this box since November, and I trusted WD to address the broken functionality introduced in their 1.01.11 update eventually, so after all this time I decided to try the prerelease and lo and behold, it’s still jacked up.  So thus, I got extremely frustrated and felt compelled to post on this forum to see who else is just as pissed as me.  And you know what?  I actually felt a little better on the inside when some other folks agreed with me.

Yes I casually read these board enough to know there are no official responses from WD,  but why do you think that is?  Since you seem so eager to assume things, then tell me, do you assume WD tech engineers working on this product are oblivious to the fact that mp4 w/ AAC playback is broken?  Or maybe the countless bug submissions and complaints from other people calling tech support might have actually gotten through to someone?  I’ll actually assume that they realize this broken functionality exists, and they are not appropriately addressing it in any reasonable timeframe and thats why I’m so mad.

I guess I didn’t realize how taboo it was to actually post a valid complaint on what is supposed to be a community board.  That isn’t to say that I don’t welcome helpful responses that offer ways to “solve” WD’s problems, but thinly guised offers of “help” thats peppered with cynicism isn’t appreciated.  You know what, Mkelley, you seem to empathize with the need for the therapeutic aspect of complaining, and you said you even do this once in a while yourself?  So how about you just read my complaints and nod with agreement and understanding, but save the snide remarks to yourself?


#8

I just went through the process of converting my library to format suitable for use on WD TV Live. I used two common programs during testing phase. Handbrake (free) and TMPGEnc (commercial). I have some HD material that’s in 1080i. Handbrake, as far as I know, cannot produce interlaced output and its deinterlace/decomb algorithms produced far worse output that TMPGEnc. TMPGEnc was able to keep output files interlaced and reproduction of such files was visually identical to the original.

But point of this post is that all MP4 files produced by TMPGEnc (AVC with AAC sound) play flawlesly on WD TV Live. No audio sync issues, no problems with FFWD/FRWD. Not so with Handbrake generated files, either MP4 or MKV. In couple of instances I had multiple audio channles and remuxed TMPGEnc produced MP4 with mkvtoolnix into MKV. Again, flawless play. So, maybe, just maybe, it’s not all fault of WD TV Live. Maybe tools used to produce files do something that’s not up to standard (not that standard is “very standard” at all).


#9

I for one thank the first poster for “bellyaching” about the MP4/AAC sync problem. It’s good to know there are other people out there having trouble with these files. While I’ll try the suggested fixes, but WDTV’s manual does say it supports MP4 and AAC files. They do have a responsibility to promptly fix the problem, and we should be upset when they’re selling hundreds of these things but can’t be bothered to post a simple fix. I returned the WDTV version 1 which played AAC just fine, thinking the version 2 would be better. Huge mistake.

I’ll contact WD via that wishlist thread, and try to contact them directly. In the meantime, bellyaching may not lead to an immediate response, but it sure feels good to know I’m not alone in this boat.

What is it about geeks that has them playing the obnoxious card when someone asks for help.


#10

I am not a techi as far as sound and video is concerned and neither am I with the WD live.

I had problems with sound drop outs and maybe sound sync with MKV/AAC files fortunately I noticed the problem before I had aquired hundreds of AAC sound files and I do convert to AC3 when I come across one.

Your not alone  people using the Plex  media center on the MAC also have sync problems with mkv and AAC.

AS I read about various AV receivers and their processing of certain files, I cannot vouch for this myself but some say when using HDMI to the receiver then passing it through to the TV there sometimes is a processing lag which may account for sync problems.

Like I said I am not a techi and I do batch convert when I come across several of them using popcorn.

It solved my problem… it might not be in the LIVE


#11

My entire library of over 1000 files, from 480P, 720P, and 1080P files are also in MP4/AAC. This is a critical format, because it is about as universal as there is. Works on itunes, PS3, XBOX 360 (if AAC is in stereo), etc. I don’t plan on demuxing and I think any player has to consider this a high priority format. I am well versed at scripting and remuxing and tools like mkvtoolnix and such, but these are geek tools, and I am a geek. MP4/AAC is a more consumer oriented format, but also provides excellent quality. Not to mention 5.1 and 7.1 sound that isn’t hindered by licensing from dolby and dts.

Whether it means anything or not, I will move past the wdtv live if this isn’t resolved. If it is, I plan on buying a few more. I also am working on a in store display with a wdtv hd that relies on mp4/aac. This format is important there, because the videos are podcasts that will be updated to the displays.

Hoping it is resolved soon.


#12

I totally agree. I recieved my WD TV Live yesterday. My complete library is MP4/AAC and the movies are unwatchable with this sync issue. Fixing this is critical for me.


#13

You have to hand it to WD thier tech support is second to none, meaning you would be better off with none. They will probably get it fixed by the time it’s obsolete at the rate they work. Can’t wait for Boxee to come out, unfortunatly I already paid for this piece of trash. how I now wish I had returned it. 

Does WD have stake in BB or vise versa. all the reviews there were so positive, don’t get it I even tried to rate the WDTV dead but nothing. Last time I trust BB reviews.

Just Venting, WD won’t listen to there customers anyhow


#14

Could someone with this issue post the MediaInfo for a file that has bad sync?  Or else confirm whether the video stream was encoded with variable frame rate (VFR)?


#15

I can tell you that all of mine are constant quality, and so therefore VBR, using high profile 264. Here is the script I use which uses latest handbrake CLI to encode the video.

#!/bin/sh

filename=$1

file=${filename##*/}

base=${file%%.*}

nice hbcli -i $filename -o /users/rgarcia/movies/output/${2}.mp4 -4 -e x264 -x b-adapt=2:rc-lookahead=50 \

–loose-anamorphic -m -q 18 -t 1 -a none $3

Constant quality of q 18.

I am on a mac, and don’t have media info. I can fire up vmware if you really need that for some of these files.


#16

Sorry, misread your post, no my files are all constant frame rate, 99% of them 23.976. They are VBR, however, which is what I thought I read in your post, not VFR.


#17

ragboy wrote:

 

 

I am on a mac, and don’t have media info. I can fire up vmware if you really need that for some of these files.

Mediainfo is a freeware program which is available for most OS’s including your mac.

http://mediainfo.sourceforge.net/en/Download


#18

If someone can provide some sample files that exhibit this problem, I can forward them to the dev team to work on this bug.


#19

So I just thought I would try out 1.02.21. I upgraded firmware, then reset to factory defaults. Then I logged onto my samba share without issue (linux server running CentOS 5.4) and am proceeding to watch an 18GB MP4/AAC file , The Transformers. Seeking seems much smoother, I am experience MUCH fewer dropouts. Like 1 every couple of minutes, not every couple of seconds like before. And so far I don’t see the crazy speed up and sync issues. Its just playing smoothly and not jumping. Now I need to keep watching stuff, and try from my TwonkyServer, etc, but so far, it seems to be a noticeable improvement. I will report back after more testing.


#20

It is definitely worlds better than 1.02.19. The crazy runaway sync issue seems to be gone, but it does occasionally stutter, but minor. Still needs to be fixed, but better. The audio drop outs with AAC are better than with 1.01.24, but still present.

When I went to 1.02.19, I immediately went back, mp4 was so bad. With 1.02.21, this is watchable in my office, but the device is still not ready for my home theater where my PS3 holds that honor. I am hoping I can get this device to work as good as the PS3, so it will take over in my theater, since the WDTVLIVE works with SRT subtitles. Subtitles is the one issue that is just not supported on the PS3.

Almost there, keep up the good work. Watching “The Replacement Killers” now, a 10GB MP4/5.1 AAC title with separate SRT subs. Aside from occasional droput, and minor stutters, it is doing well.