Firmware 2.02.32 Not playing all mp4 files


Just upgraded to 2.02.32 and found that many of my mp4 movies wouldn’t play anymore!!! Don’t know what makes these files different from the ones playing but about 40% of mp4 no longer worked! Tried, rebooting, factory reset etc with no success! Also tried re-installing from USB but the result is the same!

After reverting back to 2.01.86 my all my mp4 files are playing again! 

I reverted by downloading 2.01.86 firmware and editing the wdtvlivegen3.ver file using notepad and changing the version info to 2.02.33 (needs to be higher to be able install - don’t worry this won’t affect the firmware version, just used to trick the box to accept a lower version)

My friend has exactly the same problem. Looks like a bug… I’ll think I’ll wait until this is fixed!

Anyone else having the same issue?


Where did you find the link to that firmware. I have been looking for it.

Then click Download button.


Service Unavailable


thanks. it downloaded. but this has 5 files unlike the 1.16.13 version has 3 files, do I put all 5 files in the root of the usb or just the same 3 files as the 1.16.13 version?

All 5 and don’t forget to edit the “wdtvlivegen3.ver” as mentioned.


You The Man. Thanks it worked and now back to the perviosu firmware version

Just like microsoft, looks like WD does not do enough testing before putting out updates

Yes… I have same MP4 problem as you… will follow your downgrade instructions.

Thanks for the info


We have passed this along to support.

1 Like

UIGuru: could you please post a Mediainfo-log of a file which doesn’t work with 2.02.32, and a Mediainfo-log of a file which still works? Thanks!


If no one else figures it out before tomorrow I will upgrade again and see if I can figure out what these files have incommon.

I also noted a difference when uptating the movie info: If the mp4 file has an embedded thumbnail the it will always get overridden by what the WDTV finds online, this wasn’t the case earlier. Thumbnails also are also lagging more after the update the update.

I had a couple of Tom & Jerry movies that I ripped from the same box set. One played, the other didn’t. In my mind they should be the same format. 

Thanks! Would be nice to get this fixed!

this file won’t play. plays wit 2.01.86 and 1.16.13

Complete name : /Volumes/USBDisk2/series/Extant/S01/Extant.S01E04.HDTV.x264-LOL.mp4
Format : MPEG-4
Format profile : Base Media
Codec ID : isom
File size : 255 MiB
Duration : 40mn 52s
Overall bit rate mode : Variable
Overall bit rate : 874 Kbps
Encoded date : UTC 2014-07-30 17:13:49
Tagged date : UTC 2014-07-30 17:13:49

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L3.1
Format settings, CABAC : Yes
Format settings, ReFrames : 5 frames
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 40mn 52s
Source duration : 40mn 51s
Bit rate : 715 Kbps
Maximum bit rate : 3 319 Kbps
Width : 720 pixels
Height : 404 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.103
Stream size : 209 MiB (82%)
Source stream size : 221 MiB (86%)
Writing library : x264 core 142 r2431 ac76440
Encoding settings : cabac=1 / ref=5 / deblock=1:1:1 / analyse=0x3:0x133 / me=umh / subme=9 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=-2 / threads=16 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=60 / rc=crf / mbtree=1 / crf=19.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
Encoded date : UTC 2014-07-30 16:28:24
Tagged date : UTC 2014-07-30 17:13:50
Matrix coefficients : BT.709

ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : 40
Duration : 40mn 52s
Bit rate mode : Variable
Bit rate : 115 Kbps
Maximum bit rate : 144 Kbps
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 KHz
Compression mode : Lossy
Stream size : 33.6 MiB (13%)
Encoded date : UTC 2014-07-30 17:13:50
Tagged date : UTC 2014-07-30 17:13:50

There certainly doesn’t seem anything from the mediainfo output that makes that mp4 unusual. I just ran through some of my collection, obtained from various sources and some encoded by myself with different programs, all seem OK.

A stab in the dark this is but… I did notice that one of the resolved issues was “Resolved resume point for movies after power cycling WD TV” This means reading/writing to the .wd_tv folder on your NAS/HDD containing your mp4s, doesn’t it? Does deleting that folder help?

1 Like

it was first time played with new firmware. There is no resume point. And i dont use wd library feature

That file is playing fine for me.

267.774.498 bytes
crc FD33C515
md5 7d67579a00f1466c81fb18b664e130a2
sha1 087a162917f3e03359113efdb8b10027fc6121c7

OK fair enough just a trouble-shooting idea as all my mp4 videos play fine and I couldnt think of anything else for the moment. Back to the drawing board…

I have this problem too, with and entire series of a programme that previously played with no issue.  I don’t know how to produce a media info file though.  The files are MP4.

l’ll give rolling back a go.  TBH the updated Iplayer runs like a dog, and I don’t like the grid menu much,  so I don’t see much benifit in roling forward again unless i’ve missed something?


i will try it today once again, deleteing ale .wd_tv aand ._ files:) and doing factory reset before that :slight_smile: