Dashboard Win11 Not Working

Doing a fresh install of Dashboard on Win11, installs fine but when I launch it, the icon shows in the taskbar and systray and the app window flashes on the screen for like a nanosecond. Cant seem to get this to work and nothing seems to log errors in the windows event log or the application log file. Anyone else run into issues? Western Digital monitor this community? Thanks

It appears this version is DOA… there’s a download link for an older version in the other thread about non detection, I’m using it myself, virus scanned &safe

1 Like

Thanks I saw that thread and file but always hate downloading from those kinds of sites but if you’ve tried it, I’ll give it a go.

Tried it, unfortunately on Win11 at least it’s just a blank grey window. Oh well, will wait for an update.

@Steve73 - you can try this solution for blank window.

In version 4.0 the -disable-gpu is no longer required, so you can add just “-no-sandbox”. If you want to try with GPU enabled you can add “-enable-gpu-support”.

Thank you so much, that at least gets me working on 3.x and I’ll wait for an update to try 4.x again.

I am having the very same problem with Windows 11 and WD Dashboard ( When I launch WD Dashboard the only result is that an icon appears in the Taskbar. There is no actual application window and clicking on the icon in the Taskbar does nothing. I would post a picture, but there is nothing to show!

@LostLinuxGuy - Note that I have tried all combinations of the following with the current version of Dashboard and no combination of these parameters results in a functioning Dashboard application:
The results is always the same: there is an icon in the Taskbar and no other result - no functioning application.

try to update video drivers

My Video driver is current. I run AMD Adrenaline, which updates my video driver immediately upon release. For that matter, all the drivers on my system are current.