Cursor freezes as soon as I plug in my Elements 2TB USB 3.0 Hard Drive SOLVED!

I just bought the hard drive a few months ago and used it once to back up my desktop computer. It worked fine. I just plugged it in again. I first got a message that a driver was being loaded, then a message that the driver had been successfully installed. The WD elements does appear on the “Computer” screen, along with my C: drive and other devices.

The problem is that the cursor is almost completely frozen. It’ll freeze, then move very jerkily, then freeze again. I unplugged the WD drive, restarted the computer with the drive plugged in, and I get the same result. As soon as I unplug the drive, the cursor operates normally, as does the rest of the computer. I can’t use the computer in this condition…it takes forever to get the cursor to move just a few inches.

Forgot to mention: I’m using a Dell PC with Windows 7, 64-bit operating system.


Hi there,

Try to run a diagnostic on the drive if possible to see if the drive has any issues, also try to connect it on a different computer or using a different cable. Try to run the Diagnostic using DLG this is the software download link:

It passed the SMART test, but the cursor is still frozen. I assume the cable is good, since it passed the test. The drive worked fine on this same PC in October, 2015, and I haven’t tried to use it since. Any ideas?


whats left to do is testing on a different computer i guess. Did something happen between October and now that might have cause this ?

You are brilliant! Based on your question (“what’s changed?”), I just figured this out and believe someone needs to let Western Digital know of the issue. A few days after I received the WD drive and backed up my PC (using my old wired mouse), I received my new Amazon Basics Wireless Mouse with Nano Receiver (Black). It has a small USB receiver, which I plugged into the front USB slot on my PC.

Yesterday, when I went to use my WD drive, I plugged it into the second USB slot on the front of my PC. This slot is immediately adjacent (3/8") to the other slot, that had the wireless receiver plugged in. When I plugged in the WD cable, the mouse/cursor froze. When I unplugged the WD cable, the mouse/cursor was fine.

I just experimented with a wired mouse, plugged into the front USB jack next to the WD USB. No problem…the mouse/cursor is fine! Then I tried plugging the Amazon receiver into another USB jack on top of the computer, about 8" away. It also works fine!

Apparently there is some sort of intererence between the Amazon receiver and the WD USB cable, when they are in close proximity. (I should note that the front two slots are USB-3, with the SS symbol, and the slot on top of the computer is a USB-2).

Thanks, and please pass this along to WD if you can! (I’ll put a note to the same effect on the Amazon wireless mouse comments page).

Hi Dan and everyone else who has had this problem. I confirm that proximity of my brand new WD Elements 2Tb HD cable (USB3) to the wireless mouse/keyboard receiver (in my case, a Dell) interferes with and causes the mouse to freeze/behave erratically. Moving the wireless receiver to a USB port on opposite side of PC has cleared the problem. So glad I saw this thread and thanks.:wink: