Copy USB is greyed out in Dashboard

I’ve had my My Home device for approximately one week but after plugging in an external drive to copy some files over I cannot now connect using the USB.
The Copy USB function is now “greyed out” so I cannot access any external devices.

Any ideas anyone or is this now no good?


@Aliwest Now that we know you have a My Cloud Home use the following link for more information and see the image below the link.

Well I don’t know what has changed but the USB drive is now recognised and I am copying files over to My Home device!

I checked the link that you sent me (thank you) and all of my drives are compatible.

When I plugged the drive in, bingo it worked!

Thank you very much for your time and advice.


Ali Westerman

M: 07368 450123

Thanks for the info. I don’t know how but after looking through your information I plugged my drive in and bingo it worked. I’m copying files onto the WD drive now.

once again thanks for your time and effort


@Aliwest Glad to hear that it works.

I am having this issue currently. I have plugged a formatted NFTS wd elements 2 Tb hard drive into the usb port on the wd My cloud home and was able to copy approx 70 Gb to the elements the copy completed successfully however now “copy usb” is greyed out and I can not copy anything else. I have rebooted both devices and checked the elements drive connected via usb to a laptop and it is working normally and the copied files are there. Please advise.