Copy/TRansfer of data DIRECTLY between 2 MyCloud devices

Hello Everyone,

Is there a way to copy data from one MyCloud Device to another directly, without going thourhg the PC?

I have some 2TB to be copied, if I want to do that with a the conventional copy/paste it take a long time with ETA 2 days (over Wifi), and several hours over eth.

I’m looking for a way to make the EDMycloud2 connect and copy directly to WDMyCloud1.

I do not want to use snapshots, as that’s not the case.

Any help or advise would be appreciated.

Thank you.

How do you have the two My Clouds connected to your Network?

Both are in the same L2 and L3 domain

And mapped as network drives on my PC

If both My Cloud devices are on the same local network one can use SSH to issue commands to a My Cloud to copy data from one My Cloud to another. One can use the forum search feature, magnifying glass icon upper right, to learn more about various SSH commands, such as Rsync, that can be used for copying files from one My Cloud to another.

Thank you.

I have sshed into the device with root/welc0me.

However I’m unable to navigate through the subdirectories.

pwd shows im in root and ls shows nothing.

i tried cd but nothing.

Is there a manual on ssh access and commands?

Yes, the internet. :wink: Because the firmware typically uses Linux, basic Linux commands generally work.

It’s frustrating me :frowning: I’ve been on it for like several hours now

I have 2 devices

  1. DST IP: shares/Bashar/OLD DISK
  2. SRC IP: shares/Bashar/Films

I want to copy from to

so all files and subdirectories in Films in should go to the directory “OLD DISK” in

I tried rsync, scp and cp

“root” is the username im using to access with ssh

Can someone please tell me what should I input to achieve the above?.

See the following discussion for hints with respect to using Rsync:

hi… i tried the process mentioned above but it doesnt seem to be working… i have managed to enable SSH and login but cant seem to go any further as i cant seem to navigate to the directory where the data is…

to make it simple, i have a WD My Cloud 4tb which is full of data and all the data is in one folder under a shared folder… need to move everything in this folder including all sub-folders to the WD My Cloud EX2… both devices are on the same network…

Why cannot you navigate, when connected via SSh and using Linux commands, to the directory containing your data? What specific error or message are you seeing when using Linux commands to navigate to your data?

Its possible that depending on your single bay/single drive My Cloud version one may have a different data folder structure layout. There are two versions of the single bay/single drive My Cloud, each uses different firmware.

1 Like

i am new to linux and had no clue as to what to look for or where to find my data… i need a step by step guide :slight_smile:

You will probably need to see if there are any guides in the dedicated EX2 subforum and or where users more familiar with the EX2 may be able to help.

You will also want to take some time to learn the Linux commands you may need, as chances are good you will have to customize what ever directions you use to match your setup. I.e. where you want to copy the files from and where you want to go on the other device. There are basic rsync commands and one will have to customize it to work with their setup.

Generally this isn’t a simple process, one needs to do a little bit of learning to properly execute the commands to copy from one NAS to another. There are issues involved like security settings/SSH settings along with folder/share structure on the destination/target NAS.

1 Like

thank you for the response and advice… guess by the time i will learn it all i will be done with copying it the slow way :stuck_out_tongue:

The good thing about figuring out how to use the linux commands is one can use a number of them to do things on their My Cloud. Like previously indicated it isn’t a simple matter of just typing in “rsync” and things happen. One has to in put additional commands and include the source and target destination for the files to be copied.

Here is an example of what it takes to copy files from one NAS I use, to the My Cloud:

rsync -avz /volume1/1Unwatched/ root@

It is copying one Share on a NAS to the Public Share on the My Cloud. The command includes; some extra rsync command switches, source and destination paths of files to be copied, and it includes the My Cloud SSH user access name which is needed to login to the My Cloud using SSH. When running a rsync from one NAS to another one also typically has to input the password (in this case the root password for the My Cloud) in some fashion. To top it off, there are sometimes additional settings (like enabling SSH for example) one has to enable on both the source NAS and destination NAS.

There are various How To guides to using rsync but in almost every case one has to adjust those guides to fit the NAS they have and the directory structure that NAS uses. Here is one such generic How To guide using a different NAS brand:

I like Bennor’s suggestions. I personally need to learn this linux stuff as suggested. . .just don’t have the time (given that I work for a living).

I recently had this issue: Needed to get data from a USB drive to a NAS. . . .I normally do this from a PC wired to the network. . .fast enough. In this case, the PC was restricted to wireless only. ssssssslloooooooowwwwww.

Solution: Ran a backup job on the NAS. . .was able to run from “USB to NAS”. This does not use SSH commands, nor does it require a PC to use.

So in this case, you can use a backup job to get from NAS to USB, then use USB to NAS on the new unit.

PS: Having data on a USB in addition to the NAS is a good plan REGARDLESS. Think about fire protection. After you are done. . .put the USB drive in a safe or offsite place.