Content database

I have one problem to share my info remotely. The content database does not recogniza files by type, all are classified as “other” so the application does not see media files. I have tried to rebuild the content database. During the rebuilding process everything seems to go fine, it recognizes the type of file, it seems to create thumbnails, but when it appears to have finished all files are again classified as “other”. The DLNA media database does not seem to have this problem. Any suggestions?

I have the same problem , it does actually build the thumbnails and the number of photos are shown in the UI/Media. If you go into Twonky click on photos and you should find them all there. You put the problem differently (and better) than Me. I have been on about this for sometime, sadly nobody seems to have the answer, it seems to Me their website dept doesn’t keep in touch with the technical guys as their website says " My Cloud mobile and web access
Incredibly intuitive and easy to use, My Cloud mobile and web access are designed to help you quickly reach and organize your digital life with computers, tablets and smartphones."
WD support are looking into this for Me (I’m not holding My breathe) will keep you posted as to what happens.

Whilst waiting for WD support to get back to Me I have been conducting some (non scientific) experiments.
My conclusion is this …
Start off by deleting any existing files/folders then do a System Only Restore. I then (using windows explorer and the desktop app))
uploaded various amounts of files and folders. I found that you couldn’t upload much more than 12/13 GB at a time or the system ‘crashes’ and what you experience happens.
So My recommendation (until I get an answer from support)
!) Delete all your files and folders , once done you will see the UI is still showing files in Other , ignore.
2) Do a System Only Restore
3) Upload (using desktop app) files/folders not exceeding 14 GB in total to MY Cloud unit
4) Do nothing more until the Content Scan in the UI as shown ‘Idle’ for at least 30 mins.
You should now see all your thumbnails in your phone/windows apps
You can now upload more files and folders but don’t exceed 12/13 GB and you should be OK

Thank you for your response, but your solution is not really viable in my case, since I have more than 2TB of files. It will take a long time to back up and then upload that amount of information. Hope you get an answer from WD support soon.

Just received WDs reply, haven’t tried it yet.
The capacity amount that is displayed on the dashboard page of the MyCloud is a calculation that is done by the Cloud access service database on the drive.
It seems that the available data capacity for the volume has not been correctly calculated. This would also cause the thumbnails of the pictures not to appear in the app.

At this point it is advised to do a rebuild of the Cloud access database, to see if this resolves the issue of the dashboard showing an incorrect capacity.
You can do a rebuild of the Cloud access database via the dashboard of the drive.
Open the dashboard> Settings> General> Cloud access> Configure> Rebuild

It can take several days for the rebuild to finish depending on the amount of data that you have stored on the drive.
Please try to access the drive once again after a couple of days using the MyCloud app or WD Photos app to see if the pictures are visible with the thumbnails.

The capacity amount that is displayed on the dashboard page of the MyCloud is a calculation that is done by the Cloud access service database on the drive.

I was going to suggest that Twonky pays no part in the creation of the Dashboard file type display, since Twonky isn’t really integrated into the MyCloud. This statement rather confirms my suspicion. Twonky certainly doesn’t take days to build its media database, whereas the WD thumbnail and indexing services do take days.

I’m not sure what the ‘Cloud access service database’ is, though. Or, more specifically, which linux services are used to create and serve that database…

I’ve tried rebuilding the database twice. The problem remains.

Same for Me , will be contacting support again

I had the same Problem. After unplugging my USB Disk and rebuilding the database it worked for me.
May be an issue with USB Devices.

As it turns out, the capacity calculation done by the MC is not exactly what one expects. It also includes the free space on the attached USB drive. I have verified this and you can see the results in thread #136909 Dashboard calculation error


@beolutz that is an interesting catch regarding the USB device. Do you have any before and after to help? I initially had problems even getting the safepoints to work. It wouldn’t surprise me if that is one of the many issues with this product’s failure.

I also had trouble creating a safepoint. It seems to be the device can only handle one thing at a time. Copying files through the Network, rebuilding the database and creating a safepoint may not be the best idea to do concurrently.
Setting up the My Cloud was not nearly as flawless as advertised. I had to factory reset the device twice to find out that you have to do everything step by step.
So I copied My files to the box, than I created a safepoint and after that I rebuild the database as described by johnw1943.
After a couple of resets I can finally see my photos from my iPhone without getting an error message.
Skipping the safepoint creation and just unplugging the usb hdd and rebuilding the database worked for as well but is no Option for me.
What I didn’t achieved yet is having the safepoint to be updated every night although it is configured.

I followed your steps last night and was successful in transferring files. I captured traffic using Fiddler to see the REST API calls. I went to bed around 1AM, then while getting ready I checked around 7AM. Synching did not work. Hmm, since I had Fiddler still running I checked the captured traffic.

The WD Sync is probably displaying {deviceName} is up to date or {deviceName} is missing

HTTP/1.1 400 Bad Request
Date: Wed, 18 Nov 2015 13:13:38 GMT
Server: Apache
X-Orion-Version: 2.7
Content-Length: 125
Connection: close
Content-Type: text/plain; charset=utf-8
Content-Language: en

      "error_message":"Error in DB file location"

Here is the previous MetaDB Info request around 1AM

HTTP/1.1 200 OK
Date: Wed, 18 Nov 2015 07:02:35 GMT
Server: Apache
Vary: Accept-Encoding
X-Orion-Version: 2.7
Content-Length: 248
Content-Type: text/plain; charset=utf-8
Content-Language: en

            "path":"/{userName}/WD Sync",


@johnw1943 I have this same issue with the Content Capacity DB all screwed up. Did WD solved your issue?