Confused'n'Concerned: Disk Utility First Aid Passes, BUT, Drive Utility Test Fails

How is it that these two Utilities have differing results for the same drive?


  • MacBook Pro OS X El Capitan 10.11.6
  • WD Drive Utilities

please also note my similar question @


If the drive utility test fails then i recommend you contact WD support and get your drive replaced.

okay, thanks @Hamlet, but i still have the question.

does anyone know how one can pass & the other fail?

Ive had this same problem over and over again. I am on my 4th drive and still no answers. Very frustrated and have no confidence in my drive anymore

I checked up on this, and we actually tested your drives with both quick and extended tests, and didn’t find anything wrong with them. You may want to try the drives on another system. Are you having any other issues than just the tests coming back failed? Also, did you run the test in disk utility to see if you get the same results?

The only other system I have is a Windows system. I have tried the disk


okay, so, here’s the deal…

somebody unplugged these drives from my Mac withOUT ejecting them first.

  • a 2 TB My Passport Pro (connected via Thunderbolt)
  • a 2 TB My Book Studio (connected via Firewire 800 to Thunderbolt adapter)
  • a 2 TB My Book Studio (connected to the first My Book Studio via Firewire 800)

so i restarted then re-plugged them back in. they DID/DO mount. but i went ahead & opened the Mac Disk Utility app to run First Aid as per many years of habit.

i could do this for the My Book Studio’s, and they passed.
i could NOT do this for the My Passport Pro; wouldn’t give me an option to do so. i read some time ago that this was a known issue with the My Passport Pro’s & El Capitan; the solution was to use their (Western Digital’s) WD Drive Utilities app for such things instead.

so, i ran the tests on the My Passport Pro, & since it was there, also the 2 My Book Studio’s.
sometimes the “Quick Test” would pass on a couple of them, but every time, the “Complete Test” fails on all of them.

now, that raises a couple questions…

  1. why (as the title of this thread says) would one utility pass & the other fail?
  2. where is the “repair” function in the WD Drive Utilities app?

i don’t have any access to Windows or Linux, i only have Mac’s. in my searching i found an app that says it’ll give you the complete lowdown on a drive, so i ran the trial/demo for them. attached is a screenshot of part of it.

so i feel pretty confident that these drives are failing. so i guess what i really need to know is…
can i repair these with software or are they really dying?