Can't see NAS in the "Network" view of Windows 10


#1

Continuing the discussion from My Cloud® EX4100 Storage Device Firmware 2.10.310:

Hello everyone,

I just had this problem and solved it after spending some time on it. I just wanted to share my experience so you won’t waste more time trying to figure out what’s wrong.

I initially thought that it was due to the new firmware (2.10.310), and replied about this problem to the announcement post of this new firmware (see the linked topic at the top of this one). It still could be related to it, if the default setting for “Max SMB Protocol” was changed with this new firmware from like, SMB 1 to SMB 2 or SMB 3.

Also, I am not sure when I started having this problem, as I recently updated both my Windows 10 and the EX2100; I am not sure which one is to blame at this point.

Anyway, below is the post and the resolution I added to the announcement page. Hope it helps!

Cheers!


Can't see My Cloud devices in Network Computers on Windows 10 Home
#2

Hello,

Thanks for sharing your experience with the community.

Hope this helps other users.


#3

Hi all,
just got an EX4100 and also having the issue with not seeing the NAS in the lefthand side of Windows Explorer. Question on the whole SMB1 vs. SMB2 vs. SMB3… will changing it to SMB1 make the unit perform slower? This 1, 2, 3 is corresponding to the version iterations of SMB, correct? Meaning, v3 is what Win8 and Win Server 2012 prefer (which is why I was thinking so would Win10).

Thanks,
Brian


#4

I’m not an expert on SMB, but I assume that yes; 1, 2 and 3 should refer to SMB version as you mentioned - I can’t see anything else that it could be referring to.

Regarding the performance expectations, I guess I’ve read somewhere that using SMB 1 could make some stuff work slower, though I can’t remember “what” stuff. For example, it could be slower to discover it on your network, or perform network based operations, but I/O performance could stay the same. This is just a wild guess. I guess you’ll have to make more research on this topic on the web. It would be just speculation I can make at this point and it’ll not help you get your exact answer.

Also, I was not able to compare the performance between SMB 1 and SMB 2, so I’m sorry but I can’t directly answer your question.

One more thing (and this could be important), I’ve re-installed Windows 10 from scratch, and the problem got fixed. I can now see it on the “Network” view with SMB 2. So the new firmware might not be the one to blame.


#5

Hi folks,
I’ve got similar problems. I’m running two Windows 10 laptops, and a Windows 7 laptop, all thru the same Belkin router that the WDMycloud 2100 is connected to. And I get inconsistent results with Windows Explorer.

This is on a PRIVATE network (in terms of how Windows Network Connections sees the network profile), network discovery ON, automatic setup of connected devices ON, file and printer sharing ON, everybody in the same workgroup. Not using homegroup.

(1) Laptop N, running Windows 10 Home 64 bit “out of the box” (brand new) sees the MyCloud in WE as Computer, Media Device and Storage, as it should! Fully supports opening and using the shared folder tree on the MyCloud via that laptop.
(2) Laptop E, running Windows 10 Enterprise 64 bit, WE only shows MyCloud under “Storage”. Attempts to access its folder tree only get the MyCloud home page.
(3) Laptop S, running Windows 7 Ultimate 64 bit, WE shows the MyCloud under Media Devices and Storage, but not under Computers

The MyCloud is running SMB3 mode. Changing it to SMB 2 caused Laptop E to see the MyCloud under “media devices” and “storage,” no change on laptops S or N.

Changing it to SMB 1 still leaves Laptop N seeing MyCloud in all three places (Computer, Media, Storage), but the other two laptops still won’t see it as a Computer.

Ideas most welcome,

thanks
mike


#6

Did anyone find a solution to this. Changing back to SMB1 doesn’t seem to have the desired effect.


#7

@speedf and @notonyourtintype

Have you tried following some of the command in this link that show how to enable and disable various SMB versions for Microsoft OS ?

https://support.microsoft.com/en-au/help/2696547/how-to-detect-enable-and-disable-smbv1-smbv2-and-smbv3-in-windows-and

Try and select a common SMB level (SMB2 as a minimum due to exploits in SMB1) and go from there.

Cheers,

JediNite


#8

Not quite sure what happened but, without doing anything, it suddenly
appeared on my network!


#9

Brand new WD My Cloud EX4100, but having trouble making it work with Windows 10. I can’t get the recycle bin feature to work at all, but think this is just a result of not being able to see the device under “Network.”

Here all the specifications I can think of as being relevant:

My Cloud Firmware version: 2.30.172
Windows 10 Home version: 10.0.16299

As described by the original poster on this thread, I do not see the NAS in the “Network” view. I can connect by typing the host name or the IP. In Windows File Explorer, the NAS shows up as a “Storage” device, but that’s all. In the dashboard, I set it to SMB2 from SMB3 because some people said that helps. After restarting my computer, the SMB change took effect, but did not change the behavior, and I still could not see the NAS. (I also tried SMB1, but it seems Windows 10 doesn’t allow that any more, giving me an error message: “Restoring Network Connections: An error occurred while reconnecting U: to \wdmycloudex4100\public Microsoft Windows Network: You can’t connect to the file share because it’s not secure. This share requires the obsolete SMB1 protocol, which is unsafe and could expose your system to attack. Your system requires SMB2 or higher. For more info. on resolving this issue, see: https://go.microsoft.com/fwlink/?linkid=852747. This connection has not been restored.”)

Any ideas, including pointing me to other resources or other posts, are much appreciated as this renders the NAS much less effective.

UPDATE

I’ve messed around some more and noticed that I was seeing slightly different settings in the Windows Control Panel for these various network settings. What I learned was that the laptop where things actually work is Windows 10 Home build 15063. The computers where things don’t work is build 16299. So, seems things got broken by the new Windows build.

As always, any ideas on this are much appreciated!


#10

I had this issue but it was not the SMB settings, it was my McAfee firewall. I disabled the firewall and the MyCloud showed up in my network devices. When I turned the firewall back on, the device stayed in the network group. I have no idea why but I’m replacing McAfee anyway (free 30 version with new pc).