Can't play anything

For a while now my wdtv+ has had some issues when playing mkv’s. I would simply restart it and everything would play fine. Now it barely plays anything HD, and if it does. Video freezes after 2-3 min. Then stutters hard. I thought it was my router at first. After i upgraded from a 100/100 Linksys. To a Netgear wndr 3700 which has giga lan. Same issues :confused:

If i play any of the same files thru the usb. They play fine. I have tried different ethernet cables. I even tried streaming off my firewire ext drive. Still no diff :confused: Does anyone have any suggestions?

I am experiencing the same issue. It seems that any MKV file over 4.whatever GB’s and the WD gets all choppy. Usually within the first 20 seconds of hitting play.

Everything used to work fine.

I am using an Apple Airport router that I have always used.

The WD is hard wired to my router.

Again, everything used to work fine. 1 day about a month or so ago, everything just stopped working if it is a larger file.

Any suggestions besides the router?

Again, only reason I ask that is I have used this router with the WD Live since day 1 with no issues, till recently.

If there are settings or something in the router that I need to set/adjust, please let me know.

Any information is greatly appreciated.

If you spend a bit of time reading this forum, you will find that problems like what  you guys are describing are caused by the new firmware releases. Many of us have had to roll back the firmware to a previous version to get our systems to work the way they used to. For me, version 1.03.49 is the latest firmware without the stuttering problems.

You can look here if you want to try rolling back your firmware.

Also, have a look at this thread that describes mkv stuttering problems.

Yeah, thanks for the info. I read that yesterday, so I went back to version 1.2 and it told me that my network share was not accessible. I am going to the 1.03 version that seems to work for everyone now.

I will let you know if that fixes my issue.

Thanks for the response.

Thank you, i did read something about the newest firmware. I wasn’t sure as it has been happening for since the last few updates. Just a lot more apparent now. I rolled back to 1.03.49 and all is working like normal :smiley: I can not believe they still have not fixed the wdtv+ from remembering where i left off. Yet they manage to come out with a FW upgrade that makes it unusable :confused: Oh please can i run out and get your newer version :confused: If they ever get Xbmc running smoothly on the boxee box i think i know what i’ll be getting next. At least then i can turn it off with out losing where i left off on anything i watch.