Can't map drive using HTTP protocol [Windows 7 64 bits]

What I’ve tried to map:

Here’s the error:

Here’s the proof that, is accessible by browser:

So I’ve got two problemS and would like to know if you could help me.

1-How to map a drive using HTTP protocol? It’s not working the way I’ve tried above.

2-Why my share login is not working on the browser?(Second Image)

    I used my share credentials, but it’s not accepting it, what username and password it’s talking about?

    Why it’s not accepting my share credentials?

Thanks for your time.

Hi usrAnonymous, have you tried using WD Discovery to map your drive?

Mapping a Personal Cloud drive or WD NAS drive on a Windows PC

@jubei04, WD Discovery only maps a device that is on LAN, I want to know if it’s possible to map using HTTP protocol, because I would use it to map the device remotely using the WAN IP.

In that case you can do remote access from the website or using FTP. Check the links below for more information.

Remote access from

How to access data using FTP on a WD Personal Cloud drive and other WD NAS devices 

Thank you for your help, just to be sure, so it’s not possible to connect throut HTTP protocol?

One last question, do you know if WD My Cloud connects throught FTP?

Thank you very much for your help.

There are other methods to do remote access, but the only supported one is through the page or the WD my cloud desktop app. FTP is also a remote access option you can use, but it is not supported by WD, for more information on this you can check my previous post on this thread. 

Installing and using the WD My Cloud Desktop App

I would like to know what protocol WD My Cloud uses to transfer, because if it’s HTTP, thenit means that HTTP should be working for me too, not only for WD software.