Can't log into My Cloud using Smartware to create a backup

I have successfully set up the Smartware Pro software to back up a Windows 8 and an XP PC. However on a second XP PC I seem to have again successfully set up a connection to the My Cloud but I cannot get past the point where the Smartware asks me to enter the User Name and Password. When I enter these nothing happens so I cannot back up that PC. When accessing the My Cloud with the other two machines I’m not even asked for a User Name and Password. The PC in question is running XP with SP3. Would you please help

Welcome to the Community.

Have you tried disabling your Firewall for testing purposes as well as ensuring some networking services like Network DDE are running?

Thanks for your input Trancer. Yes I tried turning off the firewall and enabling the Network DDE service. This did not resolve the problem. My other XP PC works successfully with these turned off. I have successfuly copied files to the WD My Cloud manually but cannot get the Smartware to accept a password even when there isn’t one. Accepting a password is the real issue. No matter what password or username I use it won’t accept it.  WD Support’s solution is to reload the software and restart the NAS. This has done nothing but cause me a lot of wasted time. I would be grateful for any other Ideas.

Is WD SmartWare unable to interact even with public shares with no passwords in this particular system?

That is correct. It sees the NAS but can’t access it.

We have passed along this information to WD Support for a deeper investigation.

Thanks again Trancer. I have since noticed that I can use WD Smartware to back up to a local hard drive and to Dropbox but not to the MyCloud. To me the issue seems to be a security issue with MyCloud.

I have solved this problem. I was using Windows XP home edition and Client for Microsoft Networks was not installed. Once installed all worked ok. If anyone needs to know how to install this then get in touch.

1 Like

I had the same issue on a Windows 7 PC. Installing the Client for Microsoft Networks protocol resolved the issue.

It would be very helpful if you can share how you solved the problem because I’m having the same exact problem with my cloud accesing to wdsmartware so I can backup my data.

Hi there,

I am currently using windows 10. When I launch smartware, it shows my cloud, i select the smartware share and try to log in with my username and password which I have fully authorized to access the smartware share. Nothing happens. I can only seem to back up to the public share. Kindly advise!

I have the same problem with Windows 10. Has this been solved, yet? It’s a bit irritating.

See also Can’t login to share using WD Smartware
I am not yet sure that I have an absolute result, but (temporarily) turning off my firewall, after checking & downloading the full suite of downloads from WD, seemed to work.
Odd - there were no alerts in teh firewall.
Still to check - will it work after firewall on & restart? Don’t know. But it is working now!