Cant format my WD elements HDD on mac

Hello, i just purchased an WD elements HDD and i cant drag and drop any files on it. I checked and you need to format the drive but I have tried everything and an error message keeps showing. I runed the first aid and it said the disk had a problem but i dont know how to fix this, any idea out there?

thank you

If you’re encountering issues with your WD Elements HDD and are unable to drag and drop files onto it, it’s possible that the drive needs to be properly formatted or there may be an underlying issue with the drive itself. Here are a few steps you can try to troubleshoot the problem:

  1. Verify drive compatibility: Ensure that the WD Elements HDD is compatible with your operating system. Most WD external hard drives work with both Windows and macOS systems, but it’s worth double-checking.

  2. Reconnect the drive: Disconnect the WD Elements HDD from your computer and reconnect it using a different USB port.

  3. Check Disk Utility (macOS): Open the Disk Utility on macOS to see if the WD Elements HDD is recognized. If it’s listed, it may need to be initialized or formatted. If it’s not listed, there may be a hardware issue with the drive.

  4. Initialize and format the drive: If the WD Elements HDD is recognized but not formatted, you may need to initialize and format it.

  5. Perform a disk check: If you receive an error message during the formatting process or the drive is still not functioning properly, there may be underlying issues with the disk.

  6. Contact WD Support: If the above steps don’t resolve the issue, it’s recommended to reach out to Western Digital’s customer support for further assistance.

Remember to back up any important data before attempting any troubleshooting steps, as formatting or disk checks may result in data loss.