Can't Connect

It was working at the time even if only for a few people so it was a fix for some (even if only one person). What it does suggests is that there may be two separate issues on WD end. The manual option worked for the first issue (on 3/10), but WD introduced a second (more serious) issue when attempting to fix the first issue. Or WD shut down remote access all together on their end some time after 3/10.

One can continue to complain while they wait for WD to fix the issue, or one can bypass the WD problems and setup a VPN server and move on with having remote access to their My Cloud. Certain consumer routers (Asus for example) have the embedded option for enabling a VPN server. Or one can use free options like OpenVPN ( to setup a VPN server on their local network. Or one could even enable FTP (as insecure as it is) for remote access (port forwarding within the router). Or one can see the various past discussions on using SFTP on the single bay My Cloud.

One has options for remote access other than just sitting around waiting, or complaining about WD in these subforums, or “filing complaints” (what ever good that would do).

On a side note, any time one’s NAS (WD or others) relies on the manufacturer’s server side for remote access to one’s device there will always exist this issue of the service going down and being out of the end user’s control. At least with more expensive NAS options there exists the option for alternate methods of remote access that don’t rely on the manufacturer’s servers.

1 Like

Yes WD should have someone updating what happening. It should be noted that the EX2 and other multi bay My Cloud models may offer other methods of remote access. Like using WebDAV or FTP with SSL/TLS. See the user manual for your device, it should have more information on other methods of remote access and how to enable them. One typically would have to setup port forwarding within their network router for some of these alternate remote access methods.

1 Like

Incorrect. It was not working. If it was working it would of worked for everyone that did it. I did not work for everyone. If “it” work to fixed a few… then that is not what got it working for those few. The first issue was not fixable by end users. When WD tried to fix it, they broke more stuff.

Setting up a VPN is irrelevant. Western Digital sold a product with a service included. If they do not provide that service, they are committing multiple crimes in the US.

In regards to your statement of “One has options for remote access other than just sitting around waiting, or complaining about WD in these subforums, or “filing complaints” (what ever good that would do).”

What good that does is the States and Federal government will investigate the issue and how WD is handling it. If and when found in the wrong they will fine them. A lot of times the people wronged by the company are compensated.

US customers have the option to file formal complaints with the FTC and state consumer services. Just because you don’t know your rights as a consumer doesn’t mean everyone else can’t exercise them.

1 Like

I totally agree with you. For people like me, don’t have any knowledge on this, setting up vpn is a disaster for me

1 Like

What specific United States laws is WD violating for not timely fixing an advertised service? Can one still access their My Cloud remotely without using the web portal or the My Cloud mobile apps? The answer is yes. One can use FTP (as insecure as it is). The multi bay models may have additional possible methods of remote access. Not to mention most companies don’t offer 100% guaranteed up time on their consumer level services, they typically say they make a “best effort” to provide full time service. Like it or not that’s the argument most companies make when their service goes down for short/limited time.

Irrelevant or not there are other options one can use as they wait for WD to fix things on their end. If one doesn’t want to pursue those options that’s their choice. Shrugs. Others, including myself, will choose otherwise and continue to access our My Clouds remotely with very little inconvenience while waiting for WD to fix things on their end. Yes setting those options up may take some time/skill. But it provides a backup for when the WD remote access service stops working. A service which has gone down, for relatively short periods of time, more than a few times in the past.

Everything else you offered doesn’t change anything right now. Lawsuits may help in the future, may compensate some (mostly lawyers) in the future, may eventually (like Asus) force the company to change their practices with their firmware in the future, but nothing changes what is happening right this minute. Using VPN or FTP (SFTP) is something people can do right now to get some form of remote access back or to have as a remote access backup at some future point while they pursue other avenues with WD.

1 Like

Your response tells me you have no knowledge of US law or consumer laws at state or federal levels. I am not here to teach you US law, nor did I mention the word lawsuit.

Consumers have the right to complain, especially when they pay for a product and/or service. The federal and state government investigate things like this all the time and fine companies. This has nothing to do with filing lawsuits.

1 Like

LOL OK what ever. But in the mean time the service is still down. You can choose, as unpalatable as it may be, to use an alternate access method or not. Choice is yours. Or feel free to continue to complain and hope some WD person is actually reading these subforums. Again choice is yours. Carry on. :laughing:

On a side note, for the love of god if any WD persons are reading these threads, at least update the OS3 support page to accurately reflect these outages. Looks really bad to have a multi day outage and have your outage site ( state the service is up and no outages since last September. (Face palm!).

1 Like

I just checked and it is down again. Juicebox, zjyfrank17, and Bennor thank you all for keeping the threat alive. I do believe all of you are correct and attempt to get this straighten out. WD does need to step up to get this fixed and keep all of us up to date, appropriately. Left and right hand need to get together on this… I rely on MyCloud for my small business. This is not cool…

If I remember correctly, it has been down for 5 days lol

This outage should serve as a valuable learning experience that people should consider looking into having additional secure methods of remote access up and running for My Cloud devices they rely on for their business or for critical data.

SOLVED: Cannot Access Western Digital My Cloud on Windows 10 VIDEO

I stumbled upon this forum as i too were having the same symptom being brought up here. none of the solutions here help however i was able to find a video along with e a article that seems to at least get me able to access AND download my files from my drive using the browser interface. i made an account just to pass this along to you all.

Current Date/Time:March 14 2020 / 3/14/202

Method 1: Add a Windows Credential for your WD My Cloud account
The simplest and most widely effective fix for this issue is to simply add a Windows Credential for your WD My Cloud account to the credentials list on your Windows 10 computer. To do so, you need to:

  1. Right-click on the Start Menu to open the WinX Menu.

  2. Click on Control Panel in the WinX Menu to open it.

  3. In the Control Panel, locate and click on Credential Manager.

  4. Click on Windows Credentials.

  5. Click on the Add a Windows credential link in the top right corner of the list of Windows Credentials.

  6. Type the name you gave your WD My Cloud device into the Internet or network address bar, the username of your WD My Cloud account in the Username bar and the password to your WD My Cloud account in the Password. Click on Save.

  7. Close the Control Panel.

  8. Restart your computer, and when it boots up, you will be able to seamlessly access your WD My Cloud account.

Method 2: Fix the issue using Registry Editor
If Method 1 does not work for you, which is highly unlikely, this issue can also be fixed by editing your computer’s registry and adding a certain DWORD (32-bit) value to a specific key. To successfully gain access to your WD My Cloud account on a Windows 10 computer using this method, you need to:

PRO TIP: If the issue is with your computer or a laptop/notebook you should try using Reimage Plus which can scan the repositories and replace corrupt and missing files. This works in most cases, where the issue is originated due to a system corruption. You can download Reimage by Clicking Here

  1. Press Windows Logo key + R to bring up a Run

  2. Type regedit into the Run dialog and press the Enter key to open the Registry Editor.

  3. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation in the left pane.

  4. Click on the LanmanWorkstation key to display its contents in the right pane.

  5. Right-click on an empty space in the right pane, hover over New and click on DWORD (32-bit) value.

  6. Name the new DWORD value AllowInsecureGuestAuth.

  7. Double-click on the new value and, in the dialog that opens up, change its value to 1 and then click on OK.

  8. Close the Registry Editor and restart your computer, and when your computer boots up, you will be able to successfully access your WD My Cloud account without any issues.

Method 3: Network Reset
This method has been widely reported by users in the comments to have worked for many on Windows 10.

Hold the Windows Key and Press I
Choose Network & Internet

Make sure Status is selected in the left pane.
Scroll down and choose Network Reset, and confirm by Clicking Reset Now.

Can somebody please enlighten me as to where one finds “Cloud Service”
My Dashboard does not appear to show it!

1 Like

I have the same problem - failed connection status. And Yes, I am connected to the internet. I tried to use different cables and wi-fi networks, but the problem is still the same. Everything in my home network works fine but cloud access cant see internet connections. Any solution? :slight_smile:

1 Like

There will be many, many users who through no fault of their own now have a non-usable devise.

Quite a number will not be overly Tech Savvy and will have no idea how to resolve the problem.

But it is not down to them, it is plainly a WD generated situation and it is most certainly THEY who must

sort it and promptly!

Sadly none of the suggestions for the user to attempt have worked for me.

Until such time that WD fix the issue leave well alone, one can cause even more problems.

1 Like

Have been getting “no access” for over 7 days now, Phone number is a waste of time just keep getting “lines are busy” email likewise no answer back, stuck at home due to isolation rules. Seems to me that old rule, If it aint broke dont fix it, does not apply here, It was not broke but it is now


Yes. On the back up but yet still they need to step up its been more than a week…

My remote team has been unable to access data since 3/9/2020. I am currently on with WD tech support as I type this. WD refuses to acknowledge that they are at fault. My company, as well as many others here I’m sure, purchased this device for use in situations similar to which we find ourselves now. WD cannot/will not give an estimated time to resolution (I’ve been told “24 hours” since last Friday.). WD will not acknowledge that the device does not function, end-to-end, as advertised. WD Tech’s current solution to our issue is for us to “map the drive for local access”. In WD’s view, if the mapping works and the data can be accessed locally, there is no issue with the device, therefore no compensatory discussion. What WD fails to acknowledge is that we didn’t think we were buying just a “box” to access our data locally. We purchased this as a solution to allow for remote access to data. This is EXACTLY where my firm, as well as others here I’m sure, find themselves in need of at this time. We were led to believe that we were covered, but in stark reality, we are not. This is a major fail on WD’s part. The very scenario that this was held out to us as a solution, has now proven itself as a failed experiment/product. WD stock, as of this entry, is down 16% for the day. I’m sure lawsuits will follow as well. Good luck everyone, I hope for all of our sakes, that WD fixes this issue immediately.

1 Like

Well WD you properly screwed up our cloud access, At a guess I would think that you have been attacked by some sort of nasty thing and do not know how to rectify it, I am no PC eng but normally a reboot or some such reinstall works so I am told, However I leave this to WD brains to rectify, As stated I think law suits will follow, the way you are treating us as clients is totally unbelievable, WD need to step up and admit that the solution evades them as WD cannot put it right, So in the mean time we loyal customers suffer for WD failings

This isn’t a fix for that problem. If you have the problem everyone else has, you will see that the connection status has failed in Cloud Access in your WD My Cloud dashboard. Enabling a credential isn’t going to fix that connection issue. As many others have stated, it’s a WD problem that they do not seem keen on fixing.

1 Like

The Cloud Service is named “Cloud Access”. The remote access in is in the ON state in the image. The connection Status however is Failed.

I was able to perform the configure and change from Auto to Manual save wait a bit and moved it back to Auto and the system started forwarding again out my router. However I still cannot access the system remotely via phone (have not checked my laptop yet) as others have mentioned because the issue is with the WD service.

Most of my access is local so I am Ok at this time.