Can't connect to My Book Live Duo

So i recently moved to a new location but kept the same internet provider. When they reinstalled the internet they also gave me a new router. Before these changes, i could connect to my cloud normally.

I use windows 7. Now, when i try to right click and open through Networks, under Storage, my pc will open up My documents instead of a Public folder which leads to my cloud folder. Or if i double click it, instead of going to the mybook live duo login website, my browser cant display the page.

i popped the CD in and when i Start Discovery, itll find my cloud, with the same drive name and drive letter i had when it worked. then ill try to continue to map network drive but ill get  a Runtime Error saying

Program: E:\setup.exe

This application has requested the Runtime to terminate it in an unusual way.

Please contact the application’s support team for more information.

Any idea what the issue is or what  i need to change? i pressed the reset button on the back but maybe it didnt work

You can try to map the drive manually

type //mybookliveduo on the web browser or search bar

right click on the public folder or the one you want to map and select map network drive

make sure the firewall or internet security is not blocking the connection

i tried both and got the same results


I need assistance on how to join the HD to Domain instead of workgroup?

Also, if I connect using USB, PC can’t detect the HD…

Thank you,

You can’t do either of those. The Duo is NOT a USB drive!


Which mean only using the default workgroup and WD smartware?

How about configure to static IP address instead of dynamic?

Smartware has nothing to do with anything.   Smartware is just the backup and “dashboard” software.  I’ve never installed it, and I’ve got three MBLs on my network.

Yes, you can configure Static IP addresses.   The instructions are in the manual.