Can't access new Mybook live

Hi. Just followed the instructions and setup running the CD. Find the drive, and nothing happened when trying to map the drive. Just next step. Install smartware, everything looks fine. I can access the webgui, but nothing else. Can’t access public share or map any drive. Under my network it shows the Mybook icon, and I click it it, it redirects me to the webinterface where I can log in. What is the problem? The pc and MBL is connected to the same router wired. I’m supposed to have my pc wirelessly later. Any suggestions? I have uninstalled all the software and reinstalled it twice. Tried WDlink also.

Regards Sorensen

Hi, try using the WDlink app to map it. Check the link below for the steps.

Have tried the wdlink app. Nothing. There seem to be a problem with the whole Western Digital software and windows.

Your clicking the wrong MyBookLive icon under network in Windows. You have to click the one listed under “Computer” not the one under “Storage”

Or access it like this

Hi. Yes I know. The icon under “storage” sends me to the webinterface, the other icon is sometimes visible and when it is no username and password works, not even after a reset of the drive. As a said earlier it connects fine from my western digital live tv hd streamer.

Try following this guide

No data will be lost
Post back results


Reset MBL to factory settings during the night, uninstalled all the WD software. Now I found the drive and I managed to map the drive. But the another problem I have is the speed. I’m on a wireless network  5GHz with a usb 5GHz adapter and Linksys E2000. Connection is good, and varies from 54Mbps to 108 Mbps and can transfer files with only 3MB/s. I assume that is kind of slow. I have read another post about the slow speed on the MBL, so will search and read more about that. But so far I will never recommend MBL to anyone. Buy a real NAS is much better I think.

The wireless network is your bottleneck. The MyBookLive is amazing when you hardwire everything to a gigabit network. I get speeds of 70-100 MB/s from the MBL to my pc’s and 40-45 MB/sec to the MBL from my pc’s.