Mybook live set up on mac and working but unable to access the drive in windows 7

i bought a mybook live and plugged it into my router. my apple mac found it straight away using the western digital software, and now it works perfectly on my mac for media streaming, storage and time machine backups.

however, i’ve got 2 windows 7 pc’s and neither of them can access the drive.

western digital software on the pc will not find the drive, it says it’s not connected but windows explorer can see the drive and the 3 folders on the drive, public, smartware and timemachinebackup.

i can also map the drive using windows explorer but i cannot open any of the folders at all in windows. they are all set to be shared folders but windows won’t allow me to open any of them.

if i right click the public folder and select the properties and look at the security tab i can see 3 entries under the groups/user names.

it says Everyone, root (Unix User\root) and share (Unix Group\share). in the permissions for everyone, the tick is only in the “special permissions” box. i’ve clicked to change permissions but it won’t allow me to change permissions for any user, whether that be the root, everyone or the share.

i have this problem on both of my pc’s trying to access the network drive. i’ve disabled my firewall and virus checker and it’s still the same. i can only see the root folders on the drive, i can’t get access to any of them except on my mac.

i also can’t access the drive through internet explore. if i type the mybooklive.local into the web browser it doesn’t do anything at all.

does anybody know how i can get access to my drive on my pc’s?


whao! Got so confused, read it 3x times and still could not get it… Anyhow, check to make sure they all have the same workgroup.

well the basic thing is, the drive works perfectly on my mac. i can run all wd quick view and access the drive and set up shares and things.

on the pc i can do nothing. wd live on the pc can’t find the drive. windows explorer can see the drive but it won’t allow me to open any of the shared folders. it also won’t let me edit the permissions or anythng on the pc either.

i can map the drive to a drive letter but once i try to access the drive it tells me i don’t have permission and then it says the network drive is unavailable.