Cannot find public share

I am trying to set my mbook live. When i open files from the dashboard it just opens my documents. I downloaded wd link and while it lists the device it does not list the shares so i cannot map the public share. Tried searching \mybooklive with no results,

Any ideas? What am i doing wrong? Windows 7 pc.

I have the exact same issue on my main computer. It’s windows 7 64 bit. I can view the drive when I go to computer and click on networks. however, it will not let me map the network drive at all.

I can access the UI by typing the IP address into my web browser. It shows the shares etc, but when I click to view my files, it only shows the my documents folder of my C: drive.

i thought the drive was faulty, but I have another windows 7 64 bit pc on my network. i installed the software on that and it works no problem. However, I cannot for the life of me get this workign on my main PC.

I tried with my firewall disabled and my antivirus actually uninstalled. I tried in safe mode with networking. I cannot figure this out.

One thing I did notice is that when I installed from the CD, it first installed the drivers, then the WDlive software, then when it goes to next steps, when I click to view the files, it crashes with a windows runtime error. This happens every single time.

This did not happen at all on theother PC. Any help would be greatly appreciated.

I only got mine last week and there was no cd in the box, just a link to the website to download set up but it was very basic. I wonder if this is part of the problem.

Have just reinstalled win 7 on my 64 bit system.  Although I find ‘mybookworld’ listed under ‘storage1’ I cannot acces it and it doesn’t show in wd discovery.  As my backup is on the external drive I am a little concerned!  Help anyone?

I contacted tech support who said to make sure all folders are shown (not hidden) in folder options. Gonna try it and see if it works

I don’t think the disc makes much difference for the ethernet product. It should be plug n play with a possible driver that should auto install. Also, all of the downloads are available on the website.

I’ve looked through these forums, and many people have had this issue, and there doesn’t seem to have been any answer to it so far, which is a little worrying.

I just don’t understand why it would work on one computer, but not another.

Also, what causes runtime errors to appear? Would installing the most recent version of .net framework make any difference?

The PC can definitely see the drive, as I can access the web based UI just fine. However, it won’t map it as a network drive. Nor will it allow me to view the shares at all. It simply shows me the my documents folder on my C: drive. On the other computer, it maps it fine and allows me to see the public share with no issues.


I’ve been dealing with my man Eduardo from the WD support team and he’s been trying to help me out with this matter. I just received this email, but I’m not at home, so haven’t had a chance to try this out. If anybody else could give it a whirl, I’d be very grateful.

Here’s the email I received:

"Dear *****,


Thank you for your reply.


Given this information it is possible that the problem might lay on the Windows NetBios feature which is used to regulate the devices that are seen when they have an IP address assigned. For this case try following the steps on the link listed below in order to disable and then re-enable the NetBios on the computer to verify if this provides positives results:


Microsoft Support:


If you have any further questions, please reply to this email and we will be happy to assist you further. 


Western Digital Service and Support"

Did not work for me. Neither did the hidden folders thing. Running out of patience now. I cant call tech support when i am at my computer so its frustrating. Any more ideas?


Open a CMD window and issue the command

net view

What does it say?

It says there are no entries in the list


I don’t know if this will be any help. I’m still not home, so can’t test this. I’ve been hunting about so far and not found anything yet. Thanks.

Vishnyakov - I’ve figured out what was wrong! It appears that Microsoft Network Client was disabled for my network connection. Enabling it solve the problem!


Follow these instructions.


Here, I right clicked on my ethernet card adapter and clicked on ‘Properties’

Then I clicked on ‘Install’ then double clicked on ‘Client’, then installed ‘CLIENT FOR MICROSOFT NETWORKS’

I clicked OK and came out of the properties, restarted my PC and everything was working ok.

Good luck with this, guys.

My client for microsoft networks is already installed. When i click the add the box is empty. Still not working.

Hi Redmond358

I got the same problem, only difference is that the MyBook was working correctly until i cleaned my PC a litlle to extreme


I reinstalled Smartware and Quickview an deleted the previous network drive Z

Now i can’t make a backup in Smartware because it can not find an partition and on the PC i can not map the network drive. In the “network” the PC does find the MyBookLive so the connection is allright. I can acces the dashboard of the My Book.

Tried the mentioned Client installation but is was already installed…

Posted it also on an dutch forum so if i find a solution i wil let you know