Can't access MyCould from my network or web

Hi,
yesterday all worked fine, today cannot access mycloud from web or from mobile app.

In mobile app receive message Network Connection Error (905)

In web: nothing, when enter my login & password it just keeps going back to the login page - no message, nothing
so web url just switches from https://files.mycloud.com/index.php
to
https://idp.mycloud.com/idp/SSO.saml2

It’s ridiculous…

Have you tried from your local network?
From your browser try MyCloud.local or the IP address 192.168.1.x << if you know it.

I did all that, and couldn’t access it yesterday at all, not from my computer not from any other.
Today in the morning all is fine again, can see it in my network can log via web…

I really don’t understand it. Didn’t change anything, simply tried to log in and in worked - no idea what happened yesterday - weird stuff.

EXACTLY the same thing happened to me - no-one seems to have any answer to it. When I try and contact Support I get a ‘Sorry this service is not available’ page coming up. Am at a complete loss as to what to do