Can't access my text files anymore on OS5 update

Hi i can’t view my rich text documents after update from OS3 to OS5.
Now my wd cloud is useless can’t see my work stuff on my devices (Mobile,Tablet), this needs to be fixed a.s.a.p.

Can not view them using what app or program on what computer or mobile device? Cannot view them when accessing the My Cloud locally or when accessing the My Cloud remotely?

Hi Bennor i’m using mircosoft word app on andriod mobile and tablet remotely, can view when home locally on pc or laptop. worked fine on OS3 no problem, only got issue when device updated itself to OS5.

On my cloud app says file not supported, i click on open with, then says exporting, then shows the OS5 logo with my cloud (com.wdc.gza), then shows upload which i did it copied the file, the copied file does the same again back to square one open with.
app does not show other apps i have installed on both devices like OS3 did.

Have you installed the OS5 My Cloud app on your mobile devie?

There is apparently some differences between what OS3 My Cloud app supported and what the OS5 My Cloud app supports.

My Cloud OS 5: Feature Differences Between My Cloud OS 3 and My Cloud OS 5

If the My Cloud app see’s the file but won’t open it then one may have to download the file to their mobile device (using the My Cloud app) then use a different app on the mobile device to open that downloaded file.

Hi Bennor yes i have installed the OS5 app on mobile and tablet, that’s what’s causing the issue, it won’t show my other apps i have installed which worked with OS3, it’s only showing itself meaning it’s own app the OS5 app, the OS3 on cloud and OS3 app worked with no issue before, but OS3 app won’t work with OS5 Since since it updated to it, OS3 app shows no devices since update, had to download the OS5 app from playstore for the cloud to show up again.

also like to say thanks for trying to help.

The OS3 My Cloud app doesn’t support OS5 My Cloud devices. WD apparently has changed the OS5 My Cloud app such that certain features available on the OS3 app are not available on the OS5 My Cloud app. It appears WD decided to limit some of the files the app will open. Because of this users will have to use a separate app to open those unsupported files after the file has been downloaded to the mobile device.

Hi Bennor tried the upload files in app to device has you mentioned, but there’s no option to do that, only OS5 logo with my cloud (com.wdc.gza) underneath, when clicked only can be upload to the mycloud device which just copies the files, if i hold the file for 2 seconds options come up, one of the options is to share but the same thing as above happens, only can upload from device to cloud but not download to device which is odd, just uploaded a test photo picture just taken to the cloud, but can’t download the same picture back to mobile, the app is broken/useless at the moment until they fix it i guess.