Can't access my files

I have a MyBook Live 2TB, been using it for a year now, without problems, but now suddenly i cannot access my files from my desktop pc. It works from my laptop though, so i’m not quite sure what the problem is.

The nas shows up in the windows explorer under category Storage - as it should i suppose.

But on click it only opens the dashboard gui in my browser.

Tried to remap the drive letter, but doesn’t work.

I have the latest firmware on the nas, rebooted, restored couple times, nothing helped.

On my pc i disabled the firewall (comodo) yet nothing…

Any ideas? Getting a bit distressed :slight_smile:

Try using WDlink to map it again.

Thanks for your reply!

Unfortunately WD Link doesn’t find my device, I already tried it several times.

Little update:

Even my laptop cannot access the shares anymore…

Weirdly i can ping the ip address successfully, yet cannot connect or remap the drive…

Sometimes WD Link can find the device, but i cannot do anything with it.

If i try it in the browser (\ip\public) then it asks for user/password. Unfortunately i can’t figure out them, basically nothing is accepted, i already created new users, new password, restore, etc.


So i have an extra laptop here to test with, this is the situation atm:

Laptop 1:

MyBookLive shows up as a Computer, i can access the files, gui, everything is fine.

Laptop 2:

MyBookLive shows up as Storage, i cannot access my files, but i can access the gui. **bleep**?

Laptop 3:

MyBookLive doesn’t show up anywhere, though i can still ping it and get response. **bleep**?

I used to be able to reach it from all these computers and now its suddenly broken. What am i doing wrong? Any ideas?

I have win 7 64bit installed on all the computers.

Does the Java version matter for MyBookLive? I’ve found that the working laptop has java version 1.6.0_16 and the rest that doesn’t work have 1.7.0_0X