Cannot update firmware after manual rollback

Sorry if there is thread out there already, I searched and didnt find anything.  I did a manual rollback months ago  to 1.03.49_V (only issue I had was random audio playback wasn’t random).  I tried to upgrade yesterday as I wanted some of the new features and it just kept sticking to 1.03.49_V.  Any ideas on what I need to do?  

What do you mean?  It detects new firmware, installs it, but says you’re still at 1.03.49?  

Or it doesnt’ detect the new FW?

Are you trying to update over Network or via USB?

It detects the new firmware is available but after going through the update process, it still says 1.03.49 (and it is because no new features are present).  I’m doing this over my wireless network.  I guess I would just have to do a manual USB update, but can I skip straight to the newest firmware or do you have to go update by update?

No, you can go straight to whatever version.

Wonderful.  I tried it and it worked.  Thanks for the help!