Firmware Update Problem

Trying to update unit but every time I click update the unit hangs…

Current Firmware Level:  3.04.17

Firware Attempts:  3.07.14

Rollback Attempt:  3.01.19

Rollback Attempt:  0.00.28

* Tried updating over internet

* Tried updating to current firmware

* Tried updating to older firmware

* Tried (2) different usb thumb drives too with ALL 3 firmware attempts.

I had a problem awhile back where I thought the unit got bricked somehow.  I gave it to a youngster to see if he could get it working and he didn’t have any luck.  I decided to give it one more shot and after several attempts it miraculously came back to life (score 1 for the old guy).

However, ever since then the unit has been acting a little funny.  Very sluggish and stuff like that.  I pretty much turned off everything I could and even tried several reset device options. 

Ultimately I am just trying to put some videos on here so I can send to my sister-in-law but don’t want to send it to her if it is going to have issues.

I honestly even thought about putting it on ebay but not sure if my unit is faulty or not and believe it or not I would feel guilty selling a faulty unit :frowning:

Hello, did you tried pressing the reset button on the bottom side for 1 second?

Yes, tried that but no luck

Seems I recall reading someone put the updates on a USB HARD DRIVE (in the root) because this happened to them or the Hub was stuck in a boot loop or some wierd thing and the hub took it from the hard drive.