Live Hub Firmware update fail - any ideas?


I’ve attempted to update my live hub’s firmware using the USB method (as my internal drive had failed and been removed).

I can sucessfully get to the “updating firmware” screen using wth the firmware on the USB stick, but it just gets stuck on 0%.

I left it on all night and it didn’t move at all.

I’ve also tried the “cold flash” holding the reset button while plugging the power back in, again the same result, the machine starts to boot, gets to the firmware update screen and then just sits on 0%.

There is no visible activity from the USB stick at this point, although it happily loads the firmware from the USB before it gets to the update screen.

If I power up the unit without the USB I just get stuck on the black screen with the blue WD logo (no loading message).

Any ideas or is my unit finally dead (it’s out of warranty of course).




I have never tried updating the firmware on a WD TVLive Hub without the internal drive. I believe that could be the cause of your issue, but lets see what other user can comment on this.


Ive updated/downdated my Hub FW numerous times recently trying to fix slowness of response and hangs which have become more prevalent (and maybe because of the FW rollbacks too).  I let it boot, then unplug internet feed (wired and/or wireless), install flash drive into USB with ONLY the FW on it, and then do a factory reset. Once it reboots it shud show the FW icon. After the FW is installed I turn off the automatic update asap. The FW gets installed all the time but it still hangs quite a bit with Netflix. I am considering formatting the drive and installing an older FW cuz my problems all seemed to start with FW 3.12.13. Its worked about 2 yrs fine, but now I think I might have to get something else, but there doesn’t seem anything else thats comparable. I’d like to get news channels.


Hi everyone.

I finally resolved this with the following…

I used a smaller capacity USB stick (4GB down from 8GB) and made sure it was freshly formatted.

I plugged the USB stick into the REAR USB port with the unit OFF and then plugged in the power without holding the reset button or doing anything else, just plug it in.

After a short delay the firmware process started and completed in a matter of minutes, without error and the unit is working fine (even through it has no internal drive in it).

Things I learnt.

  1. use a small capacity USB stick freshly formatted (no extra files on it) and

  2. Use the REAR USB port if the front one is not working for you. - I would recommend you try this one first actually.

I hope this helps others.