Cannot see My Cloud in Finder on MBP

I can see and access My Cloud from my iMac & MBA at home without any issue. My new MBP cannot see it ( or my time capsule) in Finder.

It is on the same network & I can see it if I click on network in finder, it just doesn’t show under locations in Mojave. I can mount folder within it, but then they unmount if in close finder.

I am at a loss to explain why I cannot see it permanently in finder like I can on my other mac’s.

Any help out there?


I am not sure either. It has been a long time since I had a new MBP. However, I am using Mojave.

Try the following:

  1. OpenFinder
  2. click preferences
  3. Under Location Heading “tick” connected servers

See if that shows up.

In addition try connecting to it from Finder->Go->Connect to Server

and see what happens,

Thank you. I have tried all that. First option does nothing. Second one will connect to a folder on drive but disappears when I close finder unlike my iMac


Maybe I misunderstood, but try connecting to wdmycloud (as a server) not to a folder or a share. have to be on the root of the drive.

I am unable to do this, when I choose the drive to connect to, I am asked which folder I wish to choose…

OK. Do that. Connect to the server and when asked which folder/share choose any (don’t choose a subfolder). Now, it should appear in Finder.
Now click on any other locations such as a hard disk then click back on the server in Locations, it should show you all the folders (shares) in the root.

I just did that and the server appears in finder. which when clicking on it shows me the usual root of wdmycloud (in this case I used the IP address as I already have wdmycloud in locations. it showed the server with IP address).

Additionally what happens in you click on network (under locations) or from the menu bar Go-Network? do you see it?

Yes but when I close finder it disappears. On my iMac it stays connected…

just to be sure did you add it to the users? in System preferences->users and groups->login items and still disappears?

Also, Finder->preferences->connected servers is also on as well?

Yes it is

OK. let try.

  1. connect to the server
  2. closer finder.
  3. hold the option key and right click on Finder
  4. you should see relaunch option. click on that. Things will disappear for a couple seconds and it will come back. HOPEFULLY FINDER WILL REMEMBER.

You could also try mounting manually:

  1. open a terminal and create a temporary directory example TEST (mkdir ~/TEST)
  2. mount -t smbfs //guest:@IPADRESSOFSERVER/public ~/TEST

change directory to TEST


open Finder, check if it appears there then close Finder and reopen again.

Finally to unmount do

umount ~/TEST

Note; if guest does not work use the form

mount -t smbfs //username:passwrd@server/share ~/TEST

use your user name and your share and your ip address for server