Cannot Restore a Disk Image From WD New My Book 4TB Drive

Running under Windows 7 on my desk top PC, the new My Book external drive can be read and saved to. I use Acronis True Image to occasionally do a disk image backup just in case my system drive fails. This is my fourth My Book drive. I purchased this new one on 1 December, 2020. I created my first image file to it on 16Jan21. The file is there and I can see it. On 4Feb21 my PC failed to boot and load Windows, a problem with the EFI (UEFI) file. I’ve had this issue before but quickly fixed it with a restore from one of my other (older) My Book drives.

The process goes like this:

  1. Power PC down

  2. Power PC back up.

  3. As PC boots press to enter the BIOS setup.

  4. Plug in the My Book drive & insert the Acronis Recovery bootable CD

  5. Click Setup on the BIOS menu

  6. Move the UEFI icon right and place the CD icon in the first boot position

  7. Press to Save and exit

  8. The PC reboots, loading the Acronis software from the CD

  9. Within Acronis I select from the My Book drive the location of the file to be restored and then select the partition that represents the system EFI boot data and select .

  10. It replaces the boot data on the system drive in about 60 seconds, Acronis closes and the PC reboots.

  11. I again into the BIOS setup, move the UEFI icon back left to the first boot position, the CD in second, and the C: (system drive) in third place, press to save/exit, the PC boots and loads Windows is working again.

With the new My Book drive, the reboot process locks up as soon as I connect the My Book to the PC USB port. I cannot get any further than that. I’ve tried several other steps such as plugging the My Book up before powering up the PC, waiting until I’ve entered the BIOS setup and am ready to save & exit, using another USB port, etc. Whenever/wherever I plug the USB cable from the new My Book into a USB port, the boot up locks up and fails. I even tried another USB cable from an older My Book just in case that might be the problem. It was not.

My work around was to plug both the new My Book with the image I needed and my older My Book into my Windows 10 laptop. Both drives were readable. I made enough room on the older My Book to hold the image from the new My Book and copied the image from the new My Book to the Old My Book. I then took the old My Book to my Windows7 desktop PC and went through the restore process in Steps 1-10 above and was able to restore the EFI partition and get my desk top running again under Windows 7.

This is a pain in the butt. Why can I not do this with my new My Book drive?