Cannot Map or Open WDMyCloud Public Shares Folder

Hello All,

I am haivng lots of issues with My 4TB MyCloud and technical support can’t seem to figure it out.

I can access my dashboard thorugh a web browser fine.  No problems.

But if I try to go to Run and type “\192.168.1.10”, I get an error that says “The specified network name is no longer available.”

When I go to My Computer -> Map Network Drive -> And Browse, I see Network but there is nothing under it. It is completely blank, My Book does not show up.

WD Quick View is running, if I try to Map to the Public Share folder from that, it pre-populates to  “\WDMyCloud\Public”, when I hit OK, I get the same error as above, “The specified network name is no longer available.”

Is the front light of the NAS blue?

Unplug the NAS and plug it in back. The led will go white, then blink for a few seconds, then go blue.

Then log into your router, can the router see the NAS? Many routers have a UI listing the connected clients. If you see the NAS in the router, verify that the NAS IP address has not changed.

I’m having the same problem.  I have reset the NAS (unplug/plug) and then it comes back and allows me to map to it.  But a reboot or logoff causes the NAS be unrecognised and I get the error message again.  It is plugged into my AT&T router and the IP address is not changed.

I’ve have searched all over the web for a solution and this thread seems to be the only one with a similar problem to mine and given the date of jithu9684’s post, I’m guessing my issue is exactly the same as his (maybe just our routers are different).

any help would be greatly appreciated.

Yes - same problem.  My main desktop PC has the WD MyCloud 2TB drive network connected just fine.  The PC on my wife’s desk can’t map the same drive. Both PCs share the same network; both PCs can “ping” the drive IP address. Same error as above “network name no longer available”

Any suggestions?

Do you have a firewall? Try temporary disabling that.

also try rebooting the router.