Cannot access my cloud data via file explorer

I have been having trouble gaining access to my WD My CLoud via my computers file explorer. I used to be able to access my files by selecting the drop-down menu on the network tab in the file explorer; however, recently when I click the drop-down indicator it simply disappears and I cannot gain access. I used to have a workaround of accessing files on the frequent folders function, but I just upgraded my computer and can no longer do this. It did this with both my previous computer and my new one. I am on Windows 10, does anybody know how to fix this?

Chad22, I just finished struggling with this issue. Bennor and another user gave me a series of recommendations that eventually worked. Here are the threads:


@Chad22 This is probably your problem, see if it helps.


Thank you for your reply but neither of your suggestions seemed to work for me. I have tried so many different workarounds and attempts to fix but nothing seems to work. I’m going to try my luck with technical support. Thank you again.

I contacted WD tech support and they were able to solve my problem, I will share what he did for me. I was pretty simple actually, all he did was have me create a shortcut on my desktop that connected to the web address associated with my hard drive and after I did that I was able to gain access to all my files.

thanks, that worked for windows updates disable that option.

I am having the same issue and nothing has worked.I created a shortcut but maybe I did it wrong because it just opens the webpage through chrome.

This article map help resolve the issue of Windows 10 network share access.

Since unpacking my My Cloud, I cannot access my data. An older WD works fine. It is not a “cloud” product aimed at Millenials. It just hooks up and off you go. WD has really angered me. I cannot access my own data.

What specific My Cloud device do you have? The My Cloud Home is a completely separate device with different features/options than the My Cloud line. If you have a My Cloud Home, see the subforum for your My Cloud Home model.

One thing to check when using Microsoft Windows. Ensure SMB1.0 is enabled. Microsoft disabled that option in recent Windows updates and in new Windows installs.

Other things to check in Windows.

All of these are good ideas - - - > I have had issues with this myself.

My overall system has several Win10 machines and several MyCloud devices of various flavors. For awhile, I also had the problem of the MyCloud devices not reliably appearing in windows file explorer. One problem I had is that somehow (over time) I found that the windows “work group” name was different on several devices. Getting the entire system on one “work group” name seemed to make it more stable.

Giving the drive a static IP address and mapping it certainly makes it more convenient. Personally, I am not a fan of having mapped network drives (ransomware issues, and strange things can happen if the drives are not actually running all the time).

I have gotten accustomed to simply typing the drive “friendly name” in the File explorer address bar, or the drives IP address (they have static non-changing addresses). It seems to work every time.

I have the same problem and have a new PC. I have lots of files in the public share of the WDMyCloud that I now cannot access. I can still access them from the old PC. I have tried setting SMB 1.0/CIFS File Sharing Support but to no avail. I can’t access it with either the name or IP address in Windows Explorer and I cannot map a network drive to it.

Does anyone have any suggestions?

1 Like

Couple of things to check. Make sure both the My Cloud and new PC are using IP addresses in the same subnet range. Example: 192.168.1.x

Configure the network connection type so it is “Private” network and not a “Public” network. Sometimes when installing or updating Windows 10 it will configure your network connection type as a “Public” network which will block access to local network devices.

Disable any security software on the new PC as a test. Sometimes security software can block access to the My Cloud.

This was my problem and your fix worked perfectly. Thank you very much. Why does WD make this so hard?

I don’t think this resolves File Explorer failure though.

1 Like

I had a situation where the only computer which could see/access the drive was a windows 10 home computer and my windows 10 pro computers could not. If your computer is running Windows 10 pro then this fix may help.

Windows 10 pro seems to come with a group policy setting which (by default) does not let you access public shares which do not require authentication (without a password).

If that is your situation, run ‘gpedit.msc’ to launch group policy editor, then navigate to :
\Computer Configuration\Administrative Templates\Network\Lanman Workstation

and look for a setting ‘Allow insecure guest logons’ and set that to ‘Enabled

After that the drive was perfectly usable.

Source :

It was when I tried to mount a share to drive letter that i received an error message pointing me to googling for the above link.

Okay, guys… something worked for me when everything here did not. i.e. SMB 1.0/CIFS, etc. Well, they did? Perhaps… but I didn’t get anywhere until I did this, so heads up. This may work for you!

My last attempt of solving this, (it’s been days now) was finally changing the Name Of The Computer. Not the description, but the name. The name change that forces you to restart your PC to take effect. This, for me - some how forced the mapping. Perhaps it forced windows to remap everything, which makes sense - but whatever the case may be, my sons laptop now shows the MyCloud folder in FILE EXPLORER, when everything else seemed impossible. Hopefully this helps one of you guys!