Can no longer access mapped drive

Hi so i mapped my WD MyCloud in Windows 11 and set a username and password with local sharing etc and everything was working fine for weeks, so i copy and pasted over a lot of personal stuff like my family photos of my kids/grandkids etc, i was using my computer one night and it popped up ‘can no longer access Z: drive’

SO this issue i have is, i can’t get back in, i tried remapping it about 100x, i have got to the point now where i just want to get my family photos back off of the drive and put them elsewhere but my only option is to download them 1 at a time through the webapp, this is about 40 years worth of photos, 300+gb worth, it would take me forever to download them one by one, because no option to download a folder.

AS for trying to remap the drive, it just says ‘this folder cant be found’ i tried rebooting the device and the network countless times and it will not find the folder i am trying to map.

I tried logging in through the admin dashboard using the device ip, it gives me only the options to turn local access off, so i tried turning it off and on again via this and this says ‘Internal Error’ every time and nothing changes, i tried changing my username for the folder i created and it says internal error every time i try and do it and i tried changing my password and it also says internal error.

So what can i do?

I just want to get my photos off of it and then probably just use the MyCloud as a media drive because of the hassle that comes with trying to use it like a NAS.

Any help would be much appreciated.


Is this what you own?

If you own this device, have you set it up for use on your home network?

Have you tried this, \\WDMYCLOUD or the name you gave your device that has OS3.

Hi yes i have tried that it makes no difference, it just doesn’t appear.

Hi Martok, i just came home from work and was about to follow this guide but its been deleted? it seemed exactly what my problem was, could you please repost it?

Its strange i tried the 4 second reset and still the same error, i then tried the 40 second reset,l again same error and nothing changed, all of this started when i think the device did a update a few days ago.

OK thanks for the help i fixed it by clearing settings from within the device :slight_smile: all data intact thank god, time to take it off this thing.

So I tried all this including clearing settings, and still get ‘The username or password is incorrect’ when I try to map it to Z. This is on my Win11 laptop. My other Win10 PCs connect fine with the same UID and PW! This had been working fine for over a year. on Win11. Anybody got a clue whats going on here? My Cloud Home.

Works ok on my cell app too, but not on Win11.

The My Cloud Home is a completely different device than the My Cloud device that this subforum discusses. The My Cloud Home uses a different operating system than the My Cloud line. You may want to see the dedicated subforum for the My Cloud Home where users more familiar with that device may be able to assist.

My Cloud Home

Oops, I guess my head is in the Cloud…

Did the device name, passwords, or username change on the device when you reset it?

If so - - - explore issues with Windows Credential manager.

No device name, local & remote uid & password are the same. credential manager settings have been verified. All works well in WIN10 PCs and my cell app. Just Win11. Was working fine for over a year then one morning it started rejecting the UID/PW. Investigation continues!

My bet is still credential manager. Humor me; and wipe the credentials from the Win11 machine; which will force you to reenter (reset) the credentials next time you log on.

I have erased MYCLOUD credentials many times and it always refuses my UID/PW. Save erasing everything from Credential Manager, theres not much more I can do there.

If you are using a My Cloud Home you may have to use the My Cloud Home app (or other methods) to access the Home settings to change or remove user or account passwords. If that doesn’t work one may have to perform a reset. See the following WD Support Knowledgebase article for how to perform a reset on a My Cloud Home. Read the article to see what the reset does.

My Cloud Home: Pin Reset Button

Thanks Brennor. I have tried all you recommend. UID/PW reset, MYCloud Home pin reset, credential manger completely wiped etc. and still will not connect. Verified all from WIn10 PC (which still works ok). Interestingly, when I wipe all credentials UID verification failed to ALL other network shares. I am beginning to feel its a WIN 11/Dell/ perhaps drive issue, not a WDcloud issue at all.