Can I delete or rename public folder?

I don’t want a PUBLIC folder I only want for my use. So I would prefer to rename it or delete it and create another folder of my own choice. Is this possible?

As far as I know, no you can’t delete or rename the Public folder.

However, you don’t have to use it and you can create any folder you wish. 

You can either navigate to the My Cloud from your PC and create a new folder or

you can open the UI in your browser, click the Shares tab and select the add folder icon add_folder_icon.jpg


How “public” is that Public folder?

Is it safe at all? Or openly seen in web?

My home wlan net is safe… but now confused with this, for me totally new item!

No, it’s not “openly seen in web”, it’s only public to anyone with access (that you give access) to your My Cloud.

Again though, you don’t have to use that folder and can create any folder you wish and either set that folder as a public or private share.

I have PUBLIC and SMARTWARE  folders now it blacked out for some reason and can’t access it at all. I can only access the external drive I connected to and Time Machine. it won’t let me turn on access. Driving me nuts. Any one know what’s going on? THANKS~!

If you are refering to the “User Access” permissions, you can’t change that unless you turn off “Public Access” for that folder.

I’m in User access. I am the only user. It’s totally blacked out and won’t let me turn on access to public  -I"m taking about under share access tab I can’t turn anything on. how can I turn it on?  If I go into the SHARES folder it will not let me change anything either! 

I understand! I am trying this - it won’t let me change anything in the screen shot below where it says public access. It won’t let me change. Its dark and won’t change. I was able to do it with all the other folders but not the public one

where it says PUBLIC ACCESS I can’ click but nothing will happen it just stays blacked out

Sorry, didn’t understand what you where trying to do.

You can’t set the Public folder to Private.

If you don’t want anything to be Public then just don’t use that folder and it will just show up as a empty folder.  Personally, I don’t use the Public folder at all.

I just purchased the EX4 and I am new to this machine.

I would like to totally remove the Public folder. Why is this forbidden.

Also if I leave the Public folder and do not use it as it has been suggested, everyone in my network still sees it and is able to use it to copy anything they want to it,

I find that a little surprising that it cannot be deleted or set to private.

What am I missing?

Please see my post addressing control of access to public folder

Thanks for your reply Tel911.

However nowhere in the My Cloud EX4 dashboard I found where to rename a folder. The only options I have is the “Remove” and “Add” folder icons.

I can change the Share Description but not the Share name itself.

Any other suggestions?

Hi Adetti

Sorry if it doesn’t work for you ,This forun is for the WDMyCloud, the EX4 & EX2 have seperate forums


Ooops! Sorry about that. I guess I will check the correct forum.

Tel911, thank you for being so helpful! I really appreciate it!

Yes! I have exactly the same problem. Somehow is activated and I can’t change it back to Public access…Is there any ini file or something where this can be changed?

Never mind, I read from the link above, and it works…Thanks!

Please help me!

How to find this sight to My Cloud?

I am unable to find this

Thank You so much for your help!

You can “hide” the public share from your Windows computers by not sharing it via SAMBA (SMB/CIFS)

ssh to your Cloud Drive

cd /etc/samba

cp overall_share overall_share.bak

vi overall_share


BEGIN ## sharename = Public

  path = /shares/Public
  comment = Public
  public = yes
  browseable = yes
  writeable = yes
  guest ok = yes
  map read only = no


restart SAMBA with the command:

/etc/init.d/samba restart

The Public share will not show up now when browing the cloud drive via file explorer from a Windows computer using file explorer.

The Public share will still show up in the DashBoard UI under Shares and on the mobile WD Cloud App.  I still haven’t figured out what configs files it reads from for the DashBoard UI and the mobile app.  If anyone else has figured this out, please feel free to chime in.

1 Like

Hi All 

I am notquite sure how I manged it but I did mange to turn off public access to the puclic share. However this was after the system took a long time to update. I think while it was updating I tried to access it with the desktop app (the white icon) then possibly crashed the web app (the bloack icon). i did not close my browser but simply refreshed the page. From there I went back to the share page of the web app and was able to turn off the public sharing on the puclic folder. As I said I am not quite sure how I managed this, so may have manged it by accedent. My advice is to try with caution and try backing up the data before you do or at least set a safepoint to return to.