Brand New My Book Essential WDBACW0030HBK-01 doesnt show up in my computer

Hi, I’ve just purchased a brand new WD My Book Essential Drive  (Says Win7, Vista and XP compatible on the box)

It lights and spins up absolutely fine and egg timer comes on desktop and USB icon appears by the clock bottom right but that’s it!  It appears in device manager with a yellow exclamation mark with the error of driver not installed properly.

When I click to reinstall or update driver, it has a good think and then just returns the message that nothing better was found.    

When restarting the PC I just get a blank windows desktop when shutting down - almost as though something is clashing with it.

I’ve disable the firewire 1394 card completely, I’ve even rolled my computer back using system restore to last week and I get the option when pressing “update driver” to have disk and manually install the driver instead.   I’ve managed to obtain it from WD’s website but despite it trying to install WDCSAM.sys to  C:\Windows\System32\Drivers the green bar gets all the way to the end and then just hangs.   It wont finish installing it.

Any ideas please I’ve spent a whole day on this, ready many many posts.   The drive doesnt appear in drive management either.   It’s just not being seen,

One thing to note - I’ve tried it on a separate PC, with the exact same spec and it works 100% fine, the firware is bang up to date as well with the latest version.

It must therefore be something clashing on the PC in question but event log lists nothing and I’m stuck

Can anyone give any further advice please

Many thanks

Try installing the SES drivers and see if that helps.

Thanks for this. I downloaded and installed - it defaulted to C: program files \western digital Plugged in drive, USB icon appears instantly by the clock but still no drive shown in my computer!! Very frustrating. I went into device manager and up the top under drives it appears simply as “disk drive” , there is also a separate entry right down the bottom. ( something like WD Devices). No red errors or yellow exclamation marks at all. I double click on the device and it shows no driver installed. However when you click on the driver tab it clearly shows a 2011 Microsoft driver there. I choose the update driver button and if you let it automatically search it just returns after a couple of minutes the message no better driver found. If I try again but this time selecting choose my own driver to install, it gives me the option to browse and by pointing to the new c: program files \wd directory then the .inf file appears and starts to install. However, the green bar showing installation progress gets to the very end but then just hangs. Nothing further happens even when left for two hours! I just don’t get why the driver won’t fully install. I have another computer exact same spec and the drive just appears instantly. Something must be stopping the driver fully installing. Any further ideas would be much appreciated

Just a further update: I plugged a 2TB WD My Book Essntial into this PC and it works perfectly! That proves no USB issue, no driver issue as all is well. As soon as you plug 3TB drive in, it isn’t seen. Device manager shows it just as “disk drive” and with “no driver installed” On a separate PC with the exact same spec and build of windows xp it works perfectly within seconds. Just dont get what is clashing with it on our other machine. Have even tried loading within windows safe mode and also with everything restricted right down in msconfig. Still no joy! Any ideas anyone on how to perform some basic troubleshooting??