Driver for WD Essential doesn´t work

Hello, I´m from Germany and I have a big problem!

My WD Essential -WDBACW0020- BK 01 doesn´t work. I have taken a firmware update. The update was successfull. After the new start WIN 7 will not install the driver. I am searching the driver in the support. I found the WD SES driver setup(X86) msi but it doesn´t work. Befor i made the firmware update my book work ok. What can I do ?

Thank you for help


Have you tried connecting the My Book to another PC to see if the same problem happens? You can also try running a DLG test to rule out any possible hardware damage.

How to test a drive for problems using Data Lifeguard Diagnostics for Windows 

Hello Ichigo, thank you for your answer. I´ve tried the WD Essential to connect on a Notebook with WIN XP. The notebook sees it is a WD MY Book essential SES 1140 and USB Mass Storage, but than it is looking for a driver. It starts WIN searchprogram for find out a driver.

MY Book Essential doesn´t work on this computer :-(. I fear My book is damaged.

Thank you help.

Greetings Webmerlin

Did you tried running the DLG test? You can also open the Disk Management window to see if it’s recognized there.

How to access Disk Management in Windows XP, Vista, 7 or 8 to manage hard drives 

If the My Book is not recognized, it would unfortunately appear to be faulty. You can follow the link below for the steps to replace it.

How to get an RMA, (Return Merchandise Authorization) or replace a defective product under warranty 

1 Like

Hello Ichigo, thank very much for your help. _ The problem has solved. _

I phoned with the helpful and very nice staff by Western Digital. I must go back with my WIN 7 Ultimate to a earlier point of Install. Than the computer say´s WD My Book is on board. Yippppppppppppeiiiiiiiiiiiiiieeeeeeee

Thank you all people that helps me!

Best regards