Blue Screen! :(

Hi all.
I use my WD passport a lot. I plugged it in this morning as usual. The file i wanted was open since Friday, but wasn’t updated version so attempted to open the new one from my external. It disappeared when I clicked on it! Resulting in blue screen of death. Computer started fine afterwards without external plugged in.

I came home. Same thing on my personal laptop. I’ll attach a pic of the blue screen.

I can’t get it loaded up in order to do a virus scan. Won’t allow me to start in Safe Mode with the USB plugged in either but works fine otherwise.

What can I do? What are the chances my files will be recovered?
Windows has recovered from an unexpected error screen throws up this:
Problem Event Name: BlueScreen
OS Version: 6.1.7601.
Locale ID: 6153
BCCode: a
BCP1: 0000000000000000
BCP2: 0000000000000002
BCP3: 0000000000000000
BCP4: FFFFF80003089CA2
OS Version: 6_1_7601
Service Pack: 1_0
Product: 768_1

The mini dump file created is .dmp and it doesn’t open on my laptop!

Hi @BlueBell2016, that’s a concerning problem to have! So, a few questions to clarify:

If you boot your computer without the drive plugged in, you said it works properly. If you plug the drive in after it is booted, does the computer immediately crash? Or does it run okay and show the drive is connected? If it runs okay, at what point of accessing the drive/file does it have a problem?

Have you tried another drive on your computer, if you have one? Or plug this drive into another USB port on your computer? Do you have USB 3.0 ports (typically are blue, or show USB-SS next to the port) or just USB 2.0 ports? Have you tried plugging it into both of these ports to see if it works? Do you know if the drive is USB 2 or 3, or other information about it? Do you have access to a non-Windows system, like a Mac, to see if it can be accessed?

I can’t claim to know what’s causing this yet, and it might be something to work with WD support on, if it’s still under warranty. I’m just wondering what you are still able to do with it, if anything. Getting access to your data before trying to recover the drive is always important.

Hi , thanks for your reply.

When I plug it in, the computer immediately crashes. It doesn’t show the drive connected at all.
The other ports work fine as I tried another external on them.
I also have tried this particular hard drive in another laptop (so 2 laptops, 1 desktop in total) and the same problem exists.

I am going to take it to an IT person Friday but I’m anxious to solve it beforehand if possible to gather my data (I’m a primary teacher and have many documents on it that I’ve spent time on!)

Thanks for your reply thus far :slight_smile:

Edited to add, this is no longer under warranty, although I have had an issue with a file or 2 disappearing in the past, but I put it down to me not ejecting the harddrive correctly first.

Hi @BlueBell2016, what has your IT person said about it? If it immediately crashes a Windows computer, I’d want to see it tried on non-Windows. I’ve recovered drives on Linux before, but it wasn’t easy. Hopefully your friend can assist.

He said it’s either a fault with USA Controller or the enclosure. He didn’t have an enclosure machine to hook it up to so I’ve left it into an IT place that does.

If that doesn’t work, it’s for the bin . I’ve heard data recovery can cost 1000 euro and I don’t need the information THAT badly!!!

Wow, you’re right, that’s expensive! For some of these portable drives, they don’t use a standard internal drive connection, but rather have a connection built into the drive. I really hope that your IT guy can assist!

Thanks, me also! I’m a teacher so could really do with NOT losing 2 years of work!!! :grinning: If it is to be, it will be a lesson hard learned!

I would agree, teachers learning life lessons are a harsh lesson indeed! I’ve been in other conversations here about backup options, which I really should consider myself!