My Passport errors when plugged in. Code 43

I was using my passport at work and have had no issues with it ever. After work I took it home and plugged it into my desktop computer and it kept coming up with errors in device manager. 

Code 43: Windows has stopped this device because it has reported problems. A request for the usb device descriptor failed. 

When this happens the drive blinks for a few seconds then the light goes solid. 

I tried out different usb ports on my desktop, and my wifes desktop, and my server, and my laptop. Eventually i got it to work by plugging it into a powered usb 3.0 port on one of my laptops and copied off all of the data.  I took this opportunity to update the firmware but I still get the same issues when plugging it into a normal usb2 or 3 port. I have noticed it will work on a normal usb port if i unplug and replug it rapidly anywhere from 2 to 5 times. Im wondering if there is any known bug/fix or if this is something more hardware related breaking down such as the motor that turns the platters beginning to fail and needing more power. 

An update in case anyone else runs into similar issues. Seems to be a working fix so far.

  1. Plug in the drive. It will probably come up as an unrecognized device with error 43 in device manager if you have this same issue. 

  2. unplug and replug the device immediately. I left it unplugged for less than a second.  Wait to see if the drive letter comes up or if it is still erroring out. Repeat until the drive shows up normally. 

  3. Copy off all your data to another device and update the hard drive firmware (doubt firmware helps but may as well) 

  4. Use diskpart to completely wipe the drive. Warning: Be careful because you can erase incorrect drives if you mess up.

-open command prompt and type diskpart  

-run the command list disk

-find a drive that matches your drive size and type select disk 3 (or whichever drive is your portable drive)

-type detail disk  This should give you details to confirm you are working with the correct drive. Mine says WD My Passport 0748 USB Device

-type clean    This will erase all the data on the drive including the partition table. If you had data on the drive I assure you that you do not have any data on it anymore. 

  1. Re-initialize the drive and create a new partition assign drive letter etc.
  • Right click on My Computer and go to Manage then select Disk Management under the Storage tab. 

-Find your drive. It should say uninitialized.  Right click and initialize it. 

-MBR or GTP? If your 2tb or under you may as well use MBR for backwards compatibility with older systems. If your drive is larger than 2tb you will need to use GPT because of the size limit on MBR. 

-Now right click the drive again and format it. Or windows may pop up and ask you to do this automatically. Select a drive letter when formatting. 

After this I have been able to have the drive come up regularly every time I attempt to plug it in. It would still be nice to get some feedback from WD on exactly what could have happened so I can avoid this occuring in the future. If someone less tech savvy ran into this issue im sure the drive would just be determined as dead and important data could be lost forever.