Blinking Red Light on WD My Cloud 4TB

Hello All

First time on here as many are

I’ve had a WD My Cloud with 2.xx Firmware running for a bit over a year. Yesterday after a reboot the harddrive started flashing a blue LED on start up followed by a red flashing light. Like many others I could not access the hard drive at all.

I checked the network cable, tried 3 other cables and different ports on my router. I’ve tried the 4 second reboot (no response), the 40 second reboot (no response). My router doesn’t recognise a device connected to it yet the Ethernet ports are showing the correct green light.

I’ve removed the drive from the WD enclosure and have attempted to attach it via Sata to USB caddy but it isn’t being recognised

Is there anything special that I need to do to get it to be recognised? I have access to either a windows or Mac Laptop but neither see the drive

Extra Info:

I tried accessing the cloud dashboard but the request timed out

It is formatted as ext4. You will need a Linux machine, or an ext4 driver for a non-linux machine. See this thread for details: