Blinking Red LED on Front

I just dealt with this red light and wanted people to know there is one other possible cause of this warning light — it does not always mean a failure. It can simply mean that your disk utilization exceeds 95%. See http://support.wdc.com/KnowledgeBase/answer.aspx?ID=13175 Item 8. However, deleting files did NOT release the space. So I donned my Network Administrator hat — oops I forgot my password — OK, reset the device.
I open the My Cloud Dashboard, scrolled right to Settings | Utilities and ran the Disk Test. Both drives confirmed fine. Next I checked firmware but already had the latest version because I had set Enable Auto Update. So what else could it be?
I went back to the General “tab” and scrolled all the way down to Services. The Recycle Bin had been left as “never clear”. That means deleting files just placed them in the recycle bin (which was not visible in my file explorer). This explains why other posters reporting fixing the problem temporarily and then getting the red light back on. I changed the setting to clear automatically and keep deleted files only for 7 days. Then I pressed the Clear button and the red light turned to blue!
PROBLEM SOLVED
http://ca.linkedin.com/pub/george-mitchell/5/378/301

Please note that the single bay My Cloud units currently do not have a “Recycle Bin” option. The lack of a recycle bin option on the single bay My Cloud units is something that has been mentioned in at least one other thread.

https://community.wd.com/t/cannot-turn-on-recycle-bin/166807

No, I’m talking about a dual drive My Cloud Mirror drive. But the point is that many other people on various web sites point out that they thought they fixed the red light issue and it just came back. Like me they could view the drive contents but could not fix the space remaining. In other words, a very different scenario from failed drives yet all get the red light.

George Mitchell
Terra Encounters
Blog: http://www.terraencounters.blogspot.com/
LinkedIn: http://ca.linkedin.com/pub/george-mitchell/5/378/301

If you can SSH into your My Cloud. cat the following files:
/tmp/led_cur_ev
/tmp/led_cur_st
/tmp/led_err_ev
/tmp/led_err_st

These files will tell you what is causing the red led. The red led can be a warning or an error. LED_EV_SYSTEM=0
LED_EV_DISK_SMART=1
LED_EV_DISK_IO=2
LED_EV_RAID_CFG=3
LED_EV_FW_UPDATE=4
LED_EV_NETWORK=5
LED_EV_DISK_STBY=6
LED_EV_HALT=7
LED_EV_THERMO=8
LED_EV_VOLUME=9
LED_EV_DISK_LOW_CAP=10
LED_EV_DISK_UNSUPPORTED=11
LED_EV_DEGRADED_MIR=12
LED_EV_MASTER_INST=13
LED_EV_FRESH_INST=14
LED_EV_VFT_HALT=15
LED_EV_FSCK_ON_BOOT=16
Those are the different values of the led state. For errors 0-3,6,8-11,13,14 are red. For warnings
0-3,9-11 are red. For normal all colors are blue except 15,16.

RAC

1 Like

I understand you are talking about the My Cloud Mirror. However, what works for you on the My Cloud Mirror (clearing the Recycle Bin) will not work on a single bay My Cloud due to the fact the single bay My Cloud Dashboard does not have a Recycle Bin option. That is what my reply above was trying to convey.

I met the same problem here . Nicholas , any solution you sort it out this problem? I am so nervous that I would lose the data if I cannot sort it out.

1 Like

We just have the same problem.
Everything was working good until today when the red light start blinking…

Anyone found a solution about this? I need to figure out what to do ASAP…

Thanks!

1 Like

What have you tried? There are a number of threads addressing red light failures.

Have there been any changes to your network, or power glitches?

It happen yesterday and I tried the following:

  • reset 4 sec
  • reset 40 sec
  • Disconnect during the whole night and connect again.

Still nothing… I hear the HDD doing a sound like it’s starting to work but it stops suddenly. And the WD MC tries to do that 5 or 6 times before having the red blinking light…

If anyone can help me?
Thanks!

2 Likes

I have the same problem. I don’t know what to do.
Did you solve your issue? Please I will appreciate if you tell me what to do.
Regards,
Max

I’ve been having this issue contacted WD for support for now…this happened for me after my power went out and came back a few seconds later and then I was running a test AND BAM! Then issues started happening wish I never ran a test on my WD Cloud that way it would of been working still.

Devices failing to come up after a power failure are likely to be one of three problems:

  1. corruption of the file system that fsck is unable to recover from
  2. faulty PSU, unable to provide the required startup current
  3. damage to device hardware (caused by a significant glitch on the power as it went down; e.g. lightning strike tripping a power grid breaker); could be MyCloud or the router

I’m betting its the third one, had numerous occasions where I had to open the power or accidentally turned it off. DIdn’t use my WD Cloud fully…around half a gigabyte but still ■■■■■ I had some few documents that were important. Not sure what to do, WD stating I might get a new one and return this yet I can’t open the WD cloud to get my data which is absurd as it voids the warranty yet a recently ruling from a court decision from 1975 has ruled this in violation against this.

All hard drives can fail at any time. You MUST have backups of any information you consider irreplaceable.

If the data is more important to you than the dollars it would cost to replace, you can try extracting the HDD, and recovering the data. If you’re careful, no-one will know you have opened the case…

BTW, if your device was damaged by an electrical supply surge, then it’s not a warranty issue, it’s a household insurance issue. Electrical surges are not the fault of WD, so not really fair to claim on their warranty.

Of course, we don’t know that it was an electrical surge that caused the failure…

Yeah either way so far looking into returning it but looking to see if I should recover that data it’s not really much I guess only the pictures were really nice since it was some videos of my graduation then again I could care less for it then. However if you have any advice if I approach to recover the data and how to do so would be really thankful for will do some research regarding this now.

Read the link I posted. That’s why I posted it…

1 Like

Opps my bad looked like a quote from my question which was why I ignored it.

But the WD easily hackable with login root crashing harddrive was my backup…

I know this is an old topic, but my drive has been down since Dec. 2018. I wrote WD support and got this from them: My Cloud is not recognized when connected to AT&T,Pace, Arris, Ubee or Sonic Gateway Routers.

This is what they told me to do:
SOLUTION:
1 . Power off the My Cloud device
2. Connect a network switch between the My Cloud and the router
3. Power on the network switch and the My Cloud device
4. Verify that the front LED light on the My Cloud is blue
5. Make sure that the LED lights on the Ethernet port of the My Cloud device are Illuminated or blinking
6. Start the My Cloud setup process again. For assistance setting up a My Cloud device, please see Answer ID 10439: How to setup a My Cloud Storage device.

It did not help me. I been down since Nov.

I have the same issue, it has been several month. Lately, I did check the temp of my device and it doesnt exceed 28c;
I open the case to check if my HDD is failure. However, the HDD still spining and doesnt make wierd sound. I’m sure that the HDD is still in good condition.
I tried several router and LAN cable but no luck. As well as 4s reset and 40s reset.

I did solve the problem with turn off my device, plug out the network cable, then plug in back the cable after that I turn on the device.

Wolaaa, the device come back with blue LED.

Its time to made second backup