BitTorrent Sync on ex2

BitTorrent Sync is a new software (still in beta) who help you transfer files between computers. Like Dropbox and similar you can share a folder with someone else and start the syncronization but with the great value that not external server are involved. Is just  between you and the other one.

http://www.getsync.com/

SO

Since there is still no a simple way to backup my pc photographs on the wd my cloud ex2 who is in another home, i thought that installing Sync on the ex2 could be a very interesting thing.

WD you really, REALLY consider this and really consider to expand the software installable on the ex2.

So i started to do some search and i’ve found that sync is already supported by the big names competiors… 

And that’s where appeared in my mind the big screen… “a new hope”…

All i had to do was understand how to install software not already supported. 

But how?

DON’T DO THIS IS YOU DO NOT KNOW WHAT YOU ARE DOING.

Well it’s a linux system definetely… so somehow you can do it.

SSH could be helpful so i turned it on and logged in with Putty.

So i 

uname -a

( Some more informations here: http://www.anandtech.com/show/7830/western-digital-my-cloud-ex2-2bay-nas-review ) 

and discovered is a linux ARM system so i could download the right version from 

http://www.getsync.com/intl/it/download

following the instruction here:

http://help.getsync.com/customer/portal/articles/1569510-how-do-i-install-sync-?b_id=3895

and here:

http://www.maketecheasier.com/install-bittorrent-sync-on-linux-server/

i’ve found how to install something on linux with ssh.

Too bad the former guide is not updated with the right files or url so i had to save the correct version on my server and wget from there.

Magically at the step:

./btsync

 the message “BitTorrent Sync forked to background” appeared! and then…

going to “http://your-ip-address:8888”…

did not do anything. 

I know… is not what you expected… but i think that is something. And if i reached this point maybe someone could help me to reach the final goal who seems to be really really close.

So i’m here to ask you to help me going through this and ask wd to consider adding sync as a sofware.

P.S.

DON’T DO THIS IS YOU DO NOT KNOW WHAT YOU ARE DOING.

1 Like

So my first question to you would be, did you forward port 8888?  I’m not interested in doing this myself, but I had to ask…

:smiley:

not done.

as soon i’ll reach home i’ll try!

any further info about how to accomplish that?

Log in to your router and find the port forwarding section.  Add port 8888 such that it is forwarded to the IP address of you EX2 (Which you should have setup with a static or reserved IP address so it wont change.)

When you execute the latest 1.4 builds of Sync on a NAS, you should specify the --webui.listen parameter with 0.0.0.0 so that Sync listens for requests on your LAN. By default Sync binds to 127.0.0.1 and so the WebUI only will be available to localhost from the perspective of the NAS.

./btsync --webui.listen 0.0.0.0:8888
1 Like

GREAT!

now it almost works!

now i’m able to see the gui and add folder but one second after the start of a syncronization between two folder i created (one on the wd and the other on my laptop) it says: Not Enough free space on the drive…

but this seems a little strange since is 2 terabytes!!

Simmons wrote:

Not Enough free space on the drive…

but this seems a little strange since is 2 terabytes!!

Please be careful which directory you choose as a destination for Sync. It seems that you chose a directory that is on the internal flash of the NAS and not the internal HD. That’s probably not good.

The shares on the HD of the EX2 seem to be available in /shares/Volume_1

You should probably only be picking destination folders within /shares/Volume_1 of Sync’s WebUI folder picker.

As it seems that you’ve filled up the flash of your NAS, you may run in to issues with firmware updates or even general operation of your NAS. I am not an expert on how the EX2 will perform with a filled up flash partition but in general this is probably NOT A GOOD THING.

I think you should disconnect the folder your added to your NAS with the Sync WebUI, and then over SSH rm the data you tried to sync to free up the internal flash. I would be extremely cautious what you rm if you’re not familiar with what you’re doing.

1 Like

yeah i figured it out yesteday it was a permission or wrong folder problem.

Now i removed all the folder and placed one for my backups under the Volume_1/public

So… it works!

IT’S A L I V E!!!:laughing:

So sync can run (even without port forwarding) on the ex2!

Thank you very much richard-bt for the important help!

I hope this software will be added to the default from wd.

Works from outside your local lan without port forwarding?

yes.

just like the pc version you do not need to configure port forwarding…

it’s just the same user interface but just on the nas…

For example now i’m uploading and receiving files from my actual pc (at work) to the one at my home.

Sounds good.  How about a quick tutorial for the rest of us as to how you installed this?

well…

it’s just all in this topic.

The first post can give you all the answers and then the right final settings are the one that richard-bt gave me.

but the steps are:

enable ssh on ex2

so on ssh once you logged in on the ex2

create a folder:

mkdir btsync
cd btsync

since the linux version is an ARM you need to download the right version from BitTorrent Sync.

 take the installer from the web (too bad the link below do not works anymore… maybe BitTorrent placed the files somewhere else so i managed to download the right version (ARM) placed on my server and “wgot” from there)

wget http://btsync.s3-website-us-east-1.amazonaws.com/btsync_x64.tar.gz

 then you have to unpack:

tar -xvzf btsync_x64.tar.gz

and then start btsync changing the default ip as told me richard-bt

./btsync --webui.listen 0.0.0.0:8888

And then it’s done!

going to “http://your-ip-address:8888” showed the gui of Sync!

Then you need to remember to place the folder  under Volume_1 to not fill the linux memory of the system 

Despite that i really don’t know if this is somehow damaging the ex2… but now it’s working. Maybe we need more informations from who know better all the things involved.

1 Like

I have been running BTSync on my EX2 for some months now, and with latest version it seems EX2 manages to enter standby / sleep… it never happened before!

can anybody confirm this? what is RAM isage in your experience with btsync?

i’ll check and let you know.

Did the new version auto updated or did you do it manually?

What procedure did you use for installation?

I had to install it manually.

I am not good at debian, I just download and estract the btsync binary file in Public share, then I use putty or Win SCP to run it:

chmod +x /shares/Public/btsync

/shares/Public/./btsync --webui.listen 0.0.0.0:8888

that’s all.

over at btsync forum told me to play around with the config file to set a different folder rescan so as to allow the EX2 to sleep, but I did not have time to do it, and personally I expected them to look into this issue sonce it affects many NASes.

When I try to install I get the error: Bash can not run a Binary file.

Wha can I do?

So, im confused now…

All what this thing do is let me send the files directly to a person, without third party involved right? And installing it will cost me my warranty?

Yet I can do exactly the same with WD own cloud? (send links to people to download my content directly)

So whats the point?

What you can accomplish here is to have a no-middle-server backup opportunity.
The cloud of wd my cloud passes through wd.

I did not start this topic with the intent to send a file to a friend. There are several professional way to do that. But just to simplify the backup process between a computer and a wdmycloud ex2 in another network.

Said that, probably this is not the easiest way or even fast way to accomplish that. But is a start.

Why dont you connect to the frive by ftp and back up then? wouldnt it be the easiest/fastest option?

yes but not automatic and not secure.